Bug 817653 - Bug in advanced Activity query
Bug in advanced Activity query
Status: CLOSED DUPLICATE of bug 813118
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.8
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Raymond Mancy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 14:37 EDT by Bill Peck
Modified: 2014-12-07 20:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 23:47:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2012-04-30 14:37:12 EDT
Description of problem:
The advanced Activity query lets you query against System/Name and Distro/Name but it never joins these together so you end up taking down the DB server.

Version-Release number of selected component (if applicable):
0.8.2

How reproducible:
Everytime

Steps to Reproduce:
1. Select Distro/Name from Advanced query
2. Add another search item
3. Select System/Name from Advanced query
4. Fill in any values for these two
5. Execute
  
Actual results:
DB will spin and churn and probably crash. :-)
Comment 1 Raymond Mancy 2012-05-03 20:58:33 EDT
I'm trying to figure out how searching for both of these things makes sense.

Normally our search bar works by having each subsequent condition having an AND operation to the previous condition, the resulting data of each condition being a subset of the data of the previous condition. However in this case the data that System/Name filters on is unrelated to the Distro/Name data.

Unless I'm missing something, perhaps this page should be removed as part of 813118
Comment 2 Bill Peck 2012-05-04 09:59:59 EDT
The user was trying to find activity for a system running distro.  You can see how the current search bar is confusing and would lead the user to think they could do that search.
Comment 3 Raymond Mancy 2012-05-08 23:47:28 EDT
This possibility has been removed in 813118

*** This bug has been marked as a duplicate of bug 813118 ***

Note You need to log in before you can comment on or make changes to this bug.