Bug 817660 - inherit initscripts lease files where possible
inherit initscripts lease files where possible
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dan Williams
Desktop QE
:
: 607921 (view as bug list)
Depends On:
Blocks: 659725 679926 743390 1014575
  Show dependency treegraph
 
Reported: 2012-04-30 15:12 EDT by Bill Nottingham
Modified: 2014-03-16 23:30 EDT (History)
9 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-37.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:34:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
untested patch to find and copy old leasefile to new location with uuid (2.81 KB, patch)
2012-04-30 17:43 EDT, Dan Williams
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2012-04-30 15:12:21 EDT
Description of problem:

initscripts uses /var/lib/dhclient/dhclient{6}-${DEVICE}.leases as the lease file name.

It would be nice if NM could notice this as being newer/active and copy it to its own lease file on startup, allowing more seamless lease takeover.

Version-Release number of selected component (if applicable):

RHEL 6 NM
Comment 2 Dan Williams 2012-04-30 17:43:14 EDT
Created attachment 581284 [details]
untested patch to find and copy old leasefile to new location with uuid
Comment 3 RHEL Product and Program Management 2012-05-06 00:06:58 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 Paul Smith 2012-08-29 18:33:59 EDT
I think this is a duplicate of, or strongly related to, bug #607921.

Note I've just attached a patch to that bug, which modifies the sysv networking scripts to use the same lease file format as NetworkManager.  This is just another way to solve the same problem: rather than changing NetworkManager to copy the initscripts file over when it starts, we just change the initscripts file to use the same file format as NetworkManager.
Comment 5 RHEL Product and Program Management 2012-09-06 18:38:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 12 errata-xmlrpc 2013-02-21 05:34:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0429.html
Comment 13 Dan Williams 2013-02-25 08:52:00 EST
*** Bug 607921 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.