Bug 817690 - HornetQ plug-in is not compatible with HornetQ shipped with EAP 5.1.x
HornetQ plug-in is not compatible with HornetQ shipped with EAP 5.1.x
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other (Show other bugs)
JON 3.0.1
All All
high Severity high
: ---
: JON 3.1.0
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 18:08 EDT by Larry O'Leary
Modified: 2013-09-05 14:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 14:48:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry O'Leary 2012-04-30 18:08:55 EDT
Description of problem:
The HornetQ plug-in provided in the JON 3.0.1 plug-in packs does is not compatible with with the version of HornetQ provided with EAP 5.

For example, the createQueue method signature changed in the HornetQ version shipped with EAP 5 (HornetQ 2.x) however, JON is using the HornetQ plug-in version 1.0.0.CR2.

As such, when attempting to create a new queue from the JON UI, the user receives the following exception:

java.lang.reflect.UndeclaredThrowableException: Failed to invoke method 'createQueue' on component 'JMSQueueManageMO' with parameters [SimpleMetaType:java.lang.String:MyTestQueue, SimpleMetaType:java.lang.String:/queue/MyTestQueue, SimpleMetaType:java.lang.String:null, SimpleMetaType:java.lang.String:null, SimpleMetaType:int:-1, SimpleMetaType:int:10485760, SimpleMetaType:int:10, SimpleMetaType:long:0, SimpleMetaType:boolean:false, SimpleMetaType:long:1000, SimpleMetaType:boolean:false, SimpleMetaType:java.lang.String:PAGE, SimpleMetaType:java.lang.String:, SimpleMetaType:java.lang.String:].
	at org.jboss.profileservice.management.KernelBusRuntimeComponentDispatcher.invoke(KernelBusRuntimeComponentDispatcher.java:201)
	at org.jboss.profileservice.management.DelegatingComponentDispatcherImpl.invoke(DelegatingComponentDispatcherImpl.java:103)
	at sun.reflect.GeneratedMethodAccessor325.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.jboss.aop.Dispatcher.invoke(Dispatcher.java:121)
	at org.jboss.aspects.remoting.AOPRemotingInvocationHandler.invoke(AOPRemotingInvocationHandler.java:82)
	at org.jboss.profileservice.remoting.ProfileServiceInvocationHandler.invoke(ProfileServiceInvocationHandler.java:99)
	at org.jboss.remoting.ServerInvoker.invoke(ServerInvoker.java:967)
	at org.jboss.remoting.transport.socket.ServerThread.completeInvocation(ServerThread.java:791)
	at org.jboss.remoting.transport.socket.ServerThread.processInvocation(ServerThread.java:744)
	at org.jboss.remoting.transport.socket.ServerThread.dorun(ServerThread.java:548)
	at org.jboss.remoting.transport.socket.ServerThread.run(ServerThread.java:234)
Caused by: org.jboss.joinpoint.spi.JoinpointException: Method not found createQueue[java.lang.String, java.lang.String, java.lang.String, java.lang.String, int, int, int, long, boolean, long, boolean, java.lang.String, java.lang.String, java.lang.String] for class org.jboss.as.integration.hornetq.management.jms.QueueManageMO

Version-Release number of selected component (if applicable):
JON 3.0.1

How reproducible:
Always
Comment 2 bkramer 2012-05-01 04:34:07 EDT
(In reply to comment #0)

Steps to reproduce the above issue:

* JON 3.0.1 and EAP 5.1.2 with HornetQ;

1) From JON UI, navigate to JBoss instance with HornetQ and select JMS Manager resource;

2) Right click on JMS Manager and from drop down menu navigate to "Create Child" and then "JMS Queue";

3)  In the "Resource Create Wizard", enter values for New Resource Name, Name, JNDI Name and "Redistribution Delay" and press "Finish" button;

4) The following message will be shown at the top of the screen: "A request to create a resource with the name of [TestQueue] has been submitted successfully."

5) However, the "Child History" page in JON UI (JMS Manager -> Inventory -> Child History will show status = failed and the following message will be logged in the Massage Center: "Failed to invoke method 'createQueue' on component 'JMSQueueManageMO' with parameters [SimpleMetaType:java.lang.String:TestQueue, SimpleMetaType:java.lang.String:/queue/TestQueue, SimpleMetaType:java.lang.String:null, SimpleMetaType:java.lang.String:null, SimpleMetaType:int:-1, SimpleMetaType:int:10485760, SimpleMetaType:int:10, SimpleMetaType:long:0, SimpleMetaType:boolean:false, SimpleMetaType:long:1000, SimpleMetaType:boolean:false, SimpleMetaType:java.lang.String:PAGE, SimpleMetaType:java.lang.String:, SimpleMetaType:java.lang.String:]."
Comment 3 Jay Shaughnessy 2012-05-01 11:59:26 EDT
JON Master commit 64a6fa8750e3b01d4374bcc73b1b7e86e04a4482

Update the HornetQ plugin version to a version with API compatibility to
the productized version of HornetQ.  This may not be compatible with
earlier, community-only versions of HornetQ, in which case users may
need to update their HornetQ version.

Test Notes:
We must sanity check this plugin version all-around, including plugin
upgrade from an earlier JON 3.0.1 release.  Of course we must also
ensure this and all other operations work as expected.

Also, we should test https://issues.jboss.org/browse/HORNETQ-856 to see if
the issue is resolved in this version. If so we can close that Jira.


Other Notes:
Note that the HornetQ plugin has some other minor fixes in trunk and we
may want an updated plugin version for the next JON release.
Comment 4 Jay Shaughnessy 2012-05-04 16:43:24 EDT
With a JON 3.1.0 RC, built with HornetQ 2.0.0.Final I was able create a
Queue.  One caveat was that I did need to specific explicit values
for DLQ, ExpiryQ and ServerPeer.  I'm not sure if that is expected, there
was no indication in the property descriptions that they wouldn't get
defaults.

Note You need to log in before you can comment on or make changes to this bug.