Bug 817722 - unwanted runtime dep on a -devel package
unwanted runtime dep on a -devel package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-hunspell-table (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: anish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 22:25 EDT by Kalev Lember
Modified: 2015-04-12 19:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: ibus-hunspell-table-0.0.6-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 16:53:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kalev Lember 2012-04-30 22:25:13 EDT
ibus-hunspell-table currently depends on libtranslit-devel, which in turn brings in other -devel packages, including glib2-devel. Because of this, the -devel packages are also pulled in to the Live CD media.

The extra deps were introduced in ibus-hunspell-table-0.0.4-1:
-Requires: ibus
+Requires: ibus,libtranslit,libtranslit-devel,libtranslit-icu,libtranslit-m17n

http://pkgs.fedoraproject.org/gitweb/?p=ibus-hunspell-table.git;a=commitdiff;h=d5def861

Should libtranslit-devel go to BuildRequires instead?
Comment 1 Fedora Update System 2012-05-02 06:26:13 EDT
ibus-hunspell-table-0.0.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-hunspell-table-0.0.6-1.fc16
Comment 2 Fedora Update System 2012-05-02 06:26:31 EDT
ibus-hunspell-table-0.0.6-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-hunspell-table-0.0.6-1.fc15
Comment 3 Fedora Update System 2012-05-02 06:26:48 EDT
ibus-hunspell-table-0.0.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-hunspell-table-0.0.6-1.fc17
Comment 4 Fedora Update System 2012-05-02 16:53:21 EDT
ibus-hunspell-table-0.0.6-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2012-05-18 08:19:52 EDT
ibus-hunspell-table-0.0.7-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-hunspell-table-0.0.7-1.fc17
Comment 6 Fedora Update System 2012-05-18 08:20:09 EDT
ibus-hunspell-table-0.0.7-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-hunspell-table-0.0.7-1.fc16
Comment 7 Fedora Update System 2012-05-18 08:20:44 EDT
ibus-hunspell-table-0.0.7-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-hunspell-table-0.0.7-1.fc15

Note You need to log in before you can comment on or make changes to this bug.