Bug 817751 - Config tool only shows one language English(USA)
Config tool only shows one language English(USA)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
20
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 01:59 EDT by Simon Lewis
Modified: 2014-06-04 01:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: system-config-language-1.3.5-19.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-27 12:33:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
image showing list of languages (39.77 KB, image/png)
2012-05-02 00:19 EDT, Pravin Satpute
no flags Details
select langauge diaglogue (27.03 KB, image/png)
2012-05-03 14:16 EDT, Simon Lewis
no flags Details
Screenshot from F20 (18.24 KB, image/png)
2013-12-25 11:41 EST, Miro Hrončok
no flags Details

  None (edit)
Description Simon Lewis 2012-05-01 01:59:56 EDT
How to make config tool to show a list of languages including British English and German?
Comment 1 Pravin Satpute 2012-05-02 00:19:21 EDT
Created attachment 581520 [details]
image showing list of languages

It already showing it. from terminal start system-config-language and it will show the language list.

if still not clear, please give me some more information regarding what exactly required or missing.
Comment 2 Simon Lewis 2012-05-03 14:16:19 EDT
Created attachment 581921 [details]
select langauge diaglogue

Your screenshot is a lot more interesting than mine - see attachment.
Comment 3 Pravin Satpute 2012-05-07 03:05:40 EDT
I need some more information for reproducing this. example of mine testing

- Fedora 17 Beta
- system-config-language-1.3.5-10.fc17.noarch
- using gnome-shell-3.4.1-3.fc17.x86_64
- tested in locale = mr_IN.UTF-8
Comment 4 Simon Lewis 2012-05-07 15:11:48 EDT
- Fedora 16 installed from net-install-iso
- system-config-language-1.3.5-8.fc16.noarch
- gnome-shell is not installed as I am using KDE SC (currently 4.8.2)
- Occasionally I use razor-qt (from their own repo) under kwin
- locale returns:

[simon@spaceloopxl ~]$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
[simon@spaceloopxl ~]$ 

- I really would like to have German (de_DE) and British English (en_GB)

Any help you can give would be much appreciated.
Comment 5 Simon Lewis 2012-05-09 06:07:10 EDT
Any ideas?
Comment 6 Pravin Satpute 2012-05-09 09:47:42 EDT
I tried to reproduce on KDE but still no success, 
1) do you get any error msg while running it from terminal?
2) We are loading /usr/share/system-config-language/locale-list file in s-c-l, can you check its content?
Comment 7 Simon Lewis 2012-05-09 15:41:19 EDT
Hi Pravin

Thanks for your response. There are no error messages when running s-c-l from the terminal and the local list is in s-c-l's share directory.

Rather than trying to use the tool, perhaps someone can give me the commands to switch the language from the command line..?

Simon
Comment 8 Pravin Satpute 2012-05-09 23:58:21 EDT
A) for changing system language. one need to edit /etc/sysconfig/i18n file

1) take backup of that file
2) edit it 

for German (de_DE)
change LANG="en_US.UTF-8"  to LANG="de_DE.UTF-8"

for British English (en_GB)
change LANG="en_US.UTF-8"  to LANG="en_GB.UTF-8"


and restart machine
Comment 9 Simon Lewis 2012-05-11 13:31:47 EDT
OK, I have changed /etc/sysconfig/i18n to:

#LANG="en_US.UTF-8"
#SUPPORTED="en_US.UTF-8:en"
#SYSFONT="lat0-sun16"
#SYSFONTACM="iso01"
LANG="de_DE.UTF-8"
SYSFONT="latarcyrheb-sun16"

and rebooted.


On loading initram error message is:

[sdb] no caching page mode is present


kdm starts in German, and kde4 can now be switched to German with KDE's system-settings dialgoue.


I guess I need to rebuild the initram - is there a way to build initram that is multilanguage capable?
Comment 10 Pravin Satpute 2012-09-13 09:56:01 EDT
did you able to solve this problem?
Comment 11 Fedora End Of Life 2013-01-16 05:19:41 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Pravin Satpute 2013-01-22 06:14:05 EST
This works well with system-config-language-1.3.5-19.fc18
Comment 13 Parag Nemade 2013-01-31 01:37:29 EST
I am closing this for now. Can reporter please test against new s-c-l package and report a new bug please?

Thanks.
Comment 14 Miro Hrončok 2013-12-25 11:37:41 EST
I can reproduce this in Fedora 20 (updated via FedUp from F17).


$ locale
LANG=cs_CZ.utf8
LC_CTYPE="cs_CZ.utf8"
LC_NUMERIC="cs_CZ.utf8"
LC_TIME="cs_CZ.utf8"
LC_COLLATE="cs_CZ.utf8"
LC_MONETARY="cs_CZ.utf8"
LC_MESSAGES="cs_CZ.utf8"
LC_PAPER="cs_CZ.utf8"
LC_NAME="cs_CZ.utf8"
LC_ADDRESS="cs_CZ.utf8"
LC_TELEPHONE="cs_CZ.utf8"
LC_MEASUREMENT="cs_CZ.utf8"
LC_IDENTIFICATION="cs_CZ.utf8"
LC_ALL=


However, in system-config-language, I can only see English. GDM is also in English only.

Will attach screenshot.
Comment 15 Miro Hrončok 2013-12-25 11:41:13 EST
Created attachment 841561 [details]
Screenshot from F20
Comment 16 Parag Nemade 2013-12-26 00:38:50 EST
you sure you have file /etc/locale.conf?

what is output of file /etc/locale.conf?

what is output of file /etc/sysconfig/i18n?
Comment 17 Miro Hrončok 2013-12-26 07:29:14 EST
(In reply to Parag from comment #16)
> you sure you have file /etc/locale.conf?
No such file.

> what is output of file /etc/sysconfig/i18n?
LANG="cs_CZ.UTF-8"
SYSFONT="latarcyrheb-sun16"
Comment 18 Parag Nemade 2013-12-26 08:12:27 EST
Then I consider what you are saying is not related to system-config-language its systemd issue that you have no /etc/locale.conf file.

F20 reads root system language from /etc/locale.conf
Comment 19 Miro Hrončok 2013-12-26 08:27:49 EST
Should I create it?

# echo 'LANG="cs_CZ.UTF-8"' > /etc/locale.conf
Comment 20 Parag Nemade 2013-12-26 08:46:07 EST
try, it should work then.
Comment 21 Miro Hrončok 2013-12-26 09:35:14 EST
Creating it fixes the system-config-language problem.

Will check GDM soon.

Thanks
Comment 22 Miro Hrončok 2013-12-27 12:33:50 EST
Fixes GDM also.

Thanks.
Comment 23 Olivier LAHAYE 2014-06-03 08:59:23 EDT
Had the exact same problem and the worked also for me.

Maybe system-config-language could check that /etc/locale.conf is missing ad issue a warning or create a default one?
Comment 24 Parag Nemade 2014-06-03 09:40:23 EDT
This is still a issue present??

/etc/locale.conf is provided by systemd, so system-config-language should only read this file and if this is not present then its problem on your system. We can think on providing warning...
Comment 25 Simon Lewis 2014-06-04 01:25:48 EDT
(In reply to Parag from comment #24)
> This is still a issue present??
> 

Appears to be fixed, I have a full list of languages in the select language dialogue.

Note You need to log in before you can comment on or make changes to this bug.