Bug 817757 - RFE: Generate Topic Detail comment dynamically
RFE: Generate Topic Detail comment dynamically
Status: CLOSED WONTFIX
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 02:47 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-04 01:49:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-05-01 02:47:48 EDT
At the moment a "Generated Topic Detail" comment is added to topics at creation time.

This information is redundant inside the Skynet interface, but is very useful when the topic is exported, such as when a book is built. Topics are exported with human readable filenames, and having the topic ID in the topic xml aids in debugging.

The topic detail comment should be generated when the topic is streamed out of skynet however, rather than at creation time. 

Problems with generating the topic detail at creation time and then leaving it alone include desynchronisation of metadata, and also the wrong topic ID being specified if topic xml is copied wholesale [refer to https://bugzilla.redhat.com/show_bug.cgi?id=817725].

What would be useful is this:

1. Generate the topic detail comment whenever the topic is streamed out of Skynet.
2. Do not include in the topic inside Skynet;
3. Instead, show the topic detail as a summary on the same page as the Topic XML, perhaps beside it.
Comment 2 Lee Newson 2014-03-04 01:49:25 EST
Closing this since the functionality for this no longer exists and there aren't any plans to add it back. If this functionality is desired (although it's been removed for 1+ years now), then please create an RFE to have it added.

Note You need to log in before you can comment on or make changes to this bug.