Bug 817758 - rawhide ant uses jakarta-commons-logging which has been retired.
rawhide ant uses jakarta-commons-logging which has been retired.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ant (Show other bugs)
rawhide
All All
high Severity urgent
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 02:50 EDT by Krzysztof Daniel
Modified: 2016-01-31 20:56 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-03 05:51:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch proposition (2.38 KB, patch)
2012-05-01 02:53 EDT, Krzysztof Daniel
no flags Details | Diff

  None (edit)
Description Krzysztof Daniel 2012-05-01 02:50:27 EDT
Eclipse cannot be built anymore because of:

DEBUG util.py:257:  Error: Package: ant-commons-logging-1.8.3-1.fc18.noarch (build)
DEBUG util.py:257:             Requires: jakarta-commons-logging
DEBUG util.py:257:   You could try using --skip-broken to work around the problem
DEBUG util.py:257:   You could try running: rpm -Va --nofiles --nodigest

http://koji.fedoraproject.org/koji/getfile?taskID=4036614&name=root.log&offset=-4000
Comment 1 Krzysztof Daniel 2012-05-01 02:53:40 EDT
Created attachment 581306 [details]
Patch proposition
Comment 3 Krzysztof Daniel 2012-05-01 04:54:12 EDT
Both [1] and [2] require only jakarta-commons-logging, but do not buildRequire. jakarta-commons-logging is not installed during the build (refer to the root.log[1]). What's more, jakarta-commons-logging is included by ant-commons-logging, which is also not referred by any of those libraries at runtime.

But it may be impossible to install those libraries if the jakarta-commons-logging will be missing.

[1] http://koji.fedoraproject.org/koji/getfile?taskID=4038860&name=root.log
Comment 4 Gökçen Eraslan 2012-05-01 05:18:33 EDT
libbase both Requires and BuildRequires jakarta-commons-logging.
Comment 5 Krzysztof Daniel 2012-05-01 05:30:05 EDT
Ok, looks like it is working again...
http://koji.fedoraproject.org/koji/taskinfo?taskID=4038915

Closing as invalid.
Comment 6 Stanislav Ochotnicky 2012-05-02 12:00:22 EDT
I am reopening this. All packages using jakarta-commons-* names (whether BR or R) should be moved to use apache-commons-* ASAP. Those provides are not gonna be there forever.

Note You need to log in before you can comment on or make changes to this bug.