Bug 817763 - Provide a way to clear bogus locks
Summary: Provide a way to clear bogus locks
Keywords:
Status: CLOSED DUPLICATE of bug 789858
Alias: None
Product: GlusterFS
Classification: Community
Component: locks
Version: mainline
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-01 07:36 UTC by Joe Julian
Modified: 2012-05-27 17:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-27 17:54:43 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Joe Julian 2012-05-01 07:36:51 UTC
For the third time in two days, someone has come into the IRC channel with an invalid lock has been held on a file that needed to be self-healed. Unmounting all the clients did not clear it and the only way to clear it was to stop the volume and restart it.

It would be nice if there was a way to clear a lock that has been determined to be invalid. Maybe setting a special xattr from the client?

Comment 1 Joe Julian 2012-05-27 17:54:43 UTC

*** This bug has been marked as a duplicate of bug 789858 ***


Note You need to log in before you can comment on or make changes to this bug.