Bug 817780 - libAfterImage must be rebuilt fot libpng 1.5 in Fedora 17
libAfterImage must be rebuilt fot libpng 1.5 in Fedora 17
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libAfterImage (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
: 836243 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 05:04 EDT by hansvon
Modified: 2012-06-30 18:06 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-30 18:02:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hansvon 2012-05-01 05:04:49 EDT
Description of problem:

ROOT can't write png images because it seems to be built against libpng 1.2 (F17 comes with 1.5) 

Version-Release number of selected component (if applicable):
root-5.32.02-1.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. run "root"
2. enter the following code
TCanvas c("c","c",500,500);
TH1F histo("histo","histo",100,-5.,5.);
histo.FillRandom("gaus",5000);
histo.Draw();
c.SaveAs("gauss.png");

  
Actual results:
A warning message is printed:
libpng warning: Application built with libpng-1.2.44 but running with 1.5.10
Info in <TCanvas::Print>: file gauss.png has been created

But gauss.png is empty

Expected results:

gauss.png should not be empty

Additional info:
Comment 1 Mattias Ellert 2012-05-02 22:35:12 EDT
The latest root build in Fedora 17 is already built using libpng 1.5. However, root does not use libpng directtly, but uses it through libAfterImage. The libAfterImage package is not yet rebuilt using the new libpng package.

Reassigning to libAfterImage.
Comment 2 Mattias Ellert 2012-05-02 22:53:06 EDT
A patch to build libAfterImage with libpng 1,5 can be found in gentoo: 

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-libs/libafterimage/files/libafterimage-libpng15.patch

If I rebuild libAfterImage with this patch root starts working again.
Comment 3 hansvon 2012-05-08 04:09:59 EDT
Thank you. I confirm that the patch is working. I hope the maintainer of libAfterImage can rebuild the F17 package at some point.
Comment 4 Fedora Update System 2012-05-28 16:34:08 EDT
libAfterImage-1.20-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libAfterImage-1.20-5.fc16
Comment 5 Fedora Update System 2012-05-28 16:34:39 EDT
libAfterImage-1.20-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libAfterImage-1.20-5.fc17
Comment 6 Fedora Update System 2012-05-28 16:34:49 EDT
libAfterImage-1.20-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libAfterImage-1.20-5.fc15
Comment 7 Fedora Update System 2012-05-29 12:20:44 EDT
Package libAfterImage-1.20-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libAfterImage-1.20-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8568/libAfterImage-1.20-5.fc17
then log in and leave karma (feedback).
Comment 8 nvwarr 2012-06-28 09:32:56 EDT
*** Bug 836243 has been marked as a duplicate of this bug. ***
Comment 9 rueffer01 2012-06-28 13:33:45 EDT
I always updated my system, but I still had this bug and with every opening of new instance of TBrowser the error message "libpng warning: Application built with libpng-1.2.44 but running with 1.5.10" got created several times...

For me the problem was solved with updating the package libAfterImage as described in comment #7: 
   # su -c 'yum update --enablerepo=updates-testing libAfterImage-1.20-5.fc17'

So far so good, but this announcement was a month ago and in all these days the fix wasn't pushed into the "normal" repo. So please do so, otherwise a lot of people are forced to search for this bug report, like I was. The solution could be made very more easy.

Thanks a lot for your work, I appreciate that! ;)
Comment 10 nvwarr 2012-06-29 01:22:50 EDT
I second that. libAfterImage-1.20-5.fc17 also fixes my problem of creating .png files and, yes, I also noticed the problem with TBrowser. That is also fixed.
Comment 11 Fedora Update System 2012-06-30 18:02:47 EDT
libAfterImage-1.20-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-06-30 18:06:37 EDT
libAfterImage-1.20-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.