Bug 817789 - Beaker should write a default pxelinux config if one does not exist
Beaker should write a default pxelinux config if one does not exist
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.0
: ---
Assigned To: Dan Callaghan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 06:10 EDT by Dan Callaghan
Modified: 2012-06-26 02:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 02:41:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2012-05-01 06:10:28 EDT
We rely on /var/lib/tftproot/pxelinux.cfg/default (and the equivalent for other boot loaders) existing, and having a default of local boot with some sensible timeout. The Cobbler PXE menu will satisfy this constraint, but we don't want to rely on that being present. We should ship a simple default PXE config with %config(noreplace), then admins can let Cobbler replace it if desired.

This should also be documented in the admin guide.
Comment 1 Dan Callaghan 2012-05-21 01:41:15 EDT
I'm not sure that shipping the default configs under a hardcoded path of /var/lib/tftproot is the best idea. That is the default path but it is configurable -- what if the administrator is using a different path for their TFTP server?

Maybe every time we clear netboot for a system, we should also check that the corresponding default config exists and write it out if it doesn't.
Comment 2 Dan Callaghan 2012-05-22 22:56:44 EDT
(In reply to comment #0)
> We rely on /var/lib/tftproot/pxelinux.cfg/default (and the equivalent for
> other boot loaders) existing,

As far as I can tell pxelinux is the only boot loader which needs a default config.
Comment 3 Dan Callaghan 2012-05-22 23:16:25 EDT
On Gerrit: http://gerrit.beaker-project.org/1082
Comment 4 Dan Callaghan 2012-05-23 18:13:52 EDT
The more I thought about it, the less I liked packaging the default config file. Mainly because I didn't like the idea of adding Requires: tftp-server just because that package owns /var/lib/tftpboot, even though the admin might be using a completely different TFTP server (like I do in my Beaker, for example).

It turned out to be pretty easy to just write the default config if it doesn't exist, which is what the patch on Gerrit does.
Comment 6 Dan Callaghan 2012-06-26 02:41:13 EDT
Beaker 0.9.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.