Bug 817797 - mvapich2-1.8-1.el6 can't be rebuild in mock
mvapich2-1.8-1.el6 can't be rebuild in mock
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mvapich2 (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Doug Ledford
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 06:33 EDT by Levente Farkas
Modified: 2015-10-03 16:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-03 16:30:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2012-05-01 06:33:46 EDT
mvapich2-1.8-1.el6 can't be rebuild in mock on rhel-6.3 beta:

make[6]: Entering directory `/builddir/build/BUILD/mvapich2-1.8a2/psm/src/pm/mpirun/src/db'
gcc -DHAVE_CONFIG_H -I. -I../..  -I../../../../mpid/ch3/channels/common/include -I../.. -I/builddir/build/BUILD/mvapich2-1.8a2/psm/src/mpl/include -I/builddir/build/BUILD/mvapich2-1.8a2/psm/src/mp
l/include -I/builddir/build/BUILD/mvapich2-1.8a2/psm/src/openpa/src -I/builddir/build/BUILD/mvapich2-1.8a2/psm/src/openpa/src -I/builddir/build/BUILD/mvapich2-1.8a2/psm/src/mpid/ch3/include -I/bui
lddir/build/BUILD/mvapich2-1.8a2/psm/src/mpid/ch3/include -I/builddir/build/BUILD/mvapich2-1.8a2/psm/src/mpid/common/datatype -I/builddir/build/BUILD/mvapich2-1.8a2/psm/src/mpid/common/datatype -I
/builddir/build/BUILD/mvapich2-1.8a2/psm/src/mpid/common/locks -I/builddir/build/BUILD/mvapich2-1.8a2/psm/src/mpid/common/locks -I/builddir/build/BUILD/mvapich2-1.8a2/psm/src/mpid/ch3/channels/psm
/include -I/builddir/build/BUILD/mvapich2-1.8a2/psm/src/mpid/ch3/channels/psm/include -I/builddir/build/BUILD/mvapich2-1.8a2/psm/src/util/wrappers -I/builddir/build/BUILD/mvapich2-1.8a2/psm/src/ut
il/wrappers   -m64 -O3 -fno-strict-aliasing -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -g -O2 -MT text.o -MD -MP -MF .d
eps/text.Tpo -c -o text.o text.c
mv -f .deps/text.Tpo .deps/text.Po
rm -f libdb.a
cru libdb.a text.o
make[6]: cru: Command not found
make[6]: *** [libdb.a] Error 127
make[6]: Leaving directory `/builddir/build/BUILD/mvapich2-1.8a2/psm/src/pm/mpirun/src/db'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/builddir/build/BUILD/mvapich2-1.8a2/psm/src/pm/mpirun/src'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/builddir/build/BUILD/mvapich2-1.8a2/psm/src/pm/mpirun'
make[3]: Leaving directory `/builddir/build/BUILD/mvapich2-1.8a2/psm/src/pm/mpirun'
make[3]: *** [all] Error 2
make[2]: *** [all-redirect] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/mvapich2-1.8a2/psm/src/pm'
make[1]: *** [all-redirect] Error 2
make[1]: Leaving directory `/builddir/build/BUILD/mvapich2-1.8a2/psm/src'
make: *** [all-redirect] Error 2
Comment 2 RHEL Product and Program Management 2012-05-05 00:17:59 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Levente Farkas 2012-05-05 03:55:02 EDT
are you joking??? it's a bug report against rhel-6.3 beta!!!
Comment 4 Josko Plazonic 2012-06-23 19:39:33 EDT
The following one letter change fixes it for me.  It ensures that config* and ac* files have their original times and that stops make from getting confused and attempting to rerun aclocal/automake.

--- mvapich2.spec.original      2012-02-14 17:23:57.000000000 -0500
+++ mvapich2.spec       2012-06-23 19:12:00.000000000 -0400
@@ -106,7 +106,7 @@
 %setup -q -n %{name}-%{version}a2
 %ifarch x86_64
 mkdir .psm
-cp -r * .psm
+cp -ar * .psm
 %endif
 mkdir .non-psm
 mv * .non-psm
Comment 6 RHEL Product and Program Management 2013-10-13 20:41:02 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 7 John Shortt 2015-10-03 16:30:19 EDT
We are long past 6.3 beta.  If there is a problem in 6.8 beta, please reopen or submit a new BZ.

Thanks

Note You need to log in before you can comment on or make changes to this bug.