Bug 817799 - ovirt-engine-backend [Auto-Recovery]: when deactivating master domain and jboss restarts we start the domain automatically on jboss startup
ovirt-engine-backend [Auto-Recovery]: when deactivating master domain and jbo...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
low Severity high
: ---
: 3.1.0
Assigned To: mkublin
Haim
storage
:
Depends On: 829275
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 06:50 EDT by Dafna Ron
Modified: 2016-02-10 11:44 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 03:08:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (8.36 KB, application/x-xz)
2012-05-01 06:50 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-05-01 06:50:24 EDT
Created attachment 581349 [details]
log

Description of problem:

I deactivated the master domain and restarted jboss while domain was in image locked.
when jboss started the domain was started automatically. 

Version-Release number of selected component (if applicable):

si2.1

How reproducible:

100%

Steps to Reproduce:
1. deactivate master domain
2. restart jboss while domain is in image locked 
3.
  
Actual results:

when jboss starts we activate the domain automatically

Expected results:

we should not activate the domain

Additional info: log
Comment 1 Ayal Baron 2012-06-10 08:27:05 EDT
what do you mean it was started automatically?
did deactivate fail (because of the restart) - if so then this sounds fine to me.
If it succeeded then was master migrated to a different domain?
Comment 2 Dafna Ron 2012-06-10 08:41:30 EDT
deactivate did not fail because of the restart. 
deactivate was already sent to vdsm and completed, jboss restart should have no effect on commands that were already sent to vdsm
it seemed that the autorecovery started the domain since when jboss starts the domain status was checked and we start it. 

but, there is a bug https://bugzilla.redhat.com/show_bug.cgi?id=829275 for the domain status's that might be related to this bug
Comment 3 Itamar Heim 2012-06-10 10:05:55 EDT
kublin - related to bug 829275?
Comment 4 mkublin 2012-06-11 03:08:19 EDT
Actually, it is not related to auto recovery and these behaviour is not bug.
We are saving a previous status of domain which is UP, when restart happenes we are trying to return to previous status which is UP, becuase of we have not any idea when restart is occurred. After that if we will have a different status from host they will report these to us and we will handle domain in appropriate way.

To see that status of domain was changed by compensation mechanism can be see at logs:
2012-05-01 12:18:38,210 INFO  [org.ovirt.engine.core.bll.storage.DeactivateStorageDomainCommand] (MSC service thread 1-1) Command [id=647f71f2-f757-4cf2-b06e-3617e63b6d98]: Compensating CHANGED_STATUS_ONLY of org.ovirt.engine.core.common.businessentities.storage_pool; snapshot: EntityStatusSnapshot [id=fd4053d0-d4a6-4402-beaa-d923c252e7f8, status=Up].
2012-05-01 12:18:38,237 INFO  [org.ovirt.engine.core.bll.storage.DeactivateStorageDomainCommand] (MSC service thread 1-1) Command [id=647f71f2-f757-4cf2-b06e-3617e63b6d98]: Compensating CHANGED_STATUS_ONLY of org.ovirt.engine.core.common.businessentities.storage_pool_iso_map; snapshot: EntityStatusSnapshot [id=storagePoolId = fd4053d0-d4a6-4402-beaa-d923c252e7f8, storageId = b5f3c87a-2647-4353-9553-34d5a5e00f0a, status=Active].
2012-05-01 12:18:38,289 INFO  [org.ovirt.engine.core.bll.Backend] (MSC service thread 1-1) Running compensation on startup for Command : org.ovirt.engine.core.bll.storage.DeactivateStorageDomainCommand , Command Id : 647f71f2-f757-4cf2-b06e-3617e63b6d98

Note You need to log in before you can comment on or make changes to this bug.