Bug 817825 - UI hangs during Create Group dialog ...3rd-level of nested menus (see screenshot)
UI hangs during Create Group dialog ...3rd-level of nested menus (see screens...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.1.0
Unspecified Unspecified
unspecified Severity high
: ER01
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 1011503
  Show dependency treegraph
 
Reported: 2012-05-01 09:32 EDT by Mike Foley
Modified: 2014-01-02 15:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1011503 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing where the UI says "loading" but never loads (297.01 KB, image/png)
2012-05-01 09:32 EDT, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2012-05-01 09:32:34 EDT
Created attachment 581371 [details]
screenshot showing where the UI says "loading" but never loads

Description of problem:  UI hangs during Create Group dialog ...3rd-level of nested menus (see screenshot)


Version-Release number of selected component (if applicable):  RHQ4.4


How reproducible:
100%

Steps to Reproduce:
1.  Create a group
2.  in the Search criteria for "Type" ... get to the third-level of menu (see screenshot)
3.  screen says "loading" ... but it never loads 
  
Actual results:  screen says "loading" ... but it never loads 


Expected results:  3rd level of nested menu loads and is selectable as a search criteria


Additional info:  screenshot
Comment 1 Mike Foley 2012-05-01 09:35:58 EDT
FF10
Comment 2 Mike Foley 2012-05-01 14:31:12 EDT
maybe "hangs" isn't the right word ... it says "loading" and never displays the 3rd level of menu
Comment 3 Mike Foley 2012-05-08 15:33:39 EDT
per BZ triage ... crouch, loleary, foley
Comment 4 mark yarborough 2012-11-06 15:05:25 EST
Per 3.1.2 triage with loleary, mfoley, ccrouch, asantos: Okay to move to JON 3.2.
Comment 5 John Mazzitelli 2013-05-02 14:16:22 EDT
the GUI component that this menu is is a SmartGGWT IPickTreeItem:

http://www.smartclient.com/smartgwt/javadoc/com/smartgwt/client/widgets/form/fields/IPickTreeItem.html

and apparently, this is how it works. Its not hanging, there just isn't any real child menu items. We override the the setEmptyMenuMessage to "Loading..." for some unknown reason though... the default, as per the SmartGWT docs:

http://www.smartclient.com/smartgwt/javadoc/com/smartgwt/client/widgets/form/fields/PickTreeItem.html#setEmptyMenuMessage%28java.lang.String%29

is "No items to display" - maybe that would be better to show. Or maybe we think of something else to say other than "Loading..."
Comment 6 John Mazzitelli 2013-05-02 14:53:35 EDT
Looking at the items in here, I've come to the conclusion I don't like this menu :) Need to figure out a better way. The platforms are confusing in here - and why does Windows have children but the other platforms don't?
Comment 7 John Mazzitelli 2013-05-06 19:10:08 EDT
commit to master : e589245 

this is a pita. I checked in something - it doesn't show "Loading..." anymore (the label is now "No items to display"). It also shows leaf nodes now for all types.

HOWEVER, the platform plugin's platform types should have all the same children (the platform services). Instead, due to the way the type hierarchy works and the way we are loading the data, there is only one platform service type menu item (they aren't duplicated across all platform types in the menus). This means you'll see, say, the CPU item under Windows but not under anywhere else. You might see "File System" under, say, Linux but not under Windows or anything else. Its random and based on which type is loaded first.

This is not trivial to fix. I spent alot of time trying to play around with things and couldn't get it to work (I even tried using GWT Menu objects rather than IPickTreeItem objects but ran into other problems that were worse.

So, I will leave this open on the off-chance someone else wants to give this a try. At least I got it where now most types no longer show "Loading..." as a leaf node, so I got that going for me (that and total-consciousness, which is nice).
Comment 8 Heiko W. Rupp 2013-08-12 04:34:17 EDT
This was done in master some time ago, so moving to modified, as it will be in ER1
Comment 9 Jeeva Kandasamy 2013-09-24 08:53:20 EDT
Version: 3.2.0.ER1
Build Number: 54dd29c:464a643
GWT Version: 2.5.0
SmartGWT Version: 3.0

As it's show "No Items to Display" on sub menus, I'm moving this to verified state. however on some situations this fix really not suites. I have cloned this issue to track new usability issue.

Bug: https://bugzilla.redhat.com/show_bug.cgi?id=1011503

Note You need to log in before you can comment on or make changes to this bug.