Bug 817834 - [Storage][NFS] Error message after ISO domain creation.
[Storage][NFS] Error message after ISO domain creation.
Status: CLOSED DUPLICATE of bug 808874
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Daniel Erez
Haim
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 10:17 EDT by Leonid Natapov
Modified: 2016-02-10 11:41 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 07:16:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (449.22 KB, application/octet-stream)
2012-05-01 10:17 EDT, Leonid Natapov
no flags Details

  None (edit)
Description Leonid Natapov 2012-05-01 10:17:58 EDT
Created attachment 581383 [details]
logs

Getting the following error message after ISO domain creation:
---------
Error: Failed to attach Storage due to an error on the Data Center master Storage Domain. Please Activate the master Storage Domain first.
---------

Although,the creation of ISO domain succeeded and it can be successfully attached and activated. Storage domain also was activated successfully.

ovirt-engine-backend-3.1.0_0001-6.el6ev.x86_64

Didn't find any errors in the logs.
engine.log and vdsm.log attached.
Comment 1 Haim 2012-05-01 16:04:49 EDT
well, from some reason, it failed to attach the ISO domain to the pool since master domain was not (*) active, the reason you didn't see any ERRORs on log comes from the fact that it failed on CAN_DO_ACTION. 

2012-05-01 16:47:46,090 WARN  [org.ovirt.engine.core.bll.storage.AttachStorageDomainToPoolCommand] (ajp--0.0.0.0-8009-6) [67dc9ecd] CanDoAction of action AttachStorageDomainToPool failed. Reasons:VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__ATTACH,ACTION_TYPE_FAILED_MASTER_STORAGE_DOMAIN_NOT_ACTIVE

after looking on vdsm log, just after the createStorageDomain command finished, I see the following warning, which implies that the master domain is somehow corrupted. 

Thread-1934::WARNING::2012-05-01 16:45:45,722::hsm::2964::Storage.HSM::(repoStats) repoStats detected invalid master:94690d0b-1ba3-4bef-9783-265fcc3682eb {'finish': 1335879941.1764369, 'mdasize': 0, 'result': {'delay': '0.00150108337402', 'lastCheck': 1335879941.1764369, 'code': 0, 'valid': True}, 'mdavalid': True, 'masterValidate': {'mount': False, 'valid': True}, 'diskfree': '290973286400', 'mdafree': 0, 'disktotal': '898360147968', 'mdathreshold': True}

Saggi - please go over vdsm log, how did we end up with invalid master again?
Comment 3 Haim 2012-06-11 07:16:36 EDT

*** This bug has been marked as a duplicate of bug 808874 ***

Note You need to log in before you can comment on or make changes to this bug.