Bug 817840 - [abrt] pocketsphinx-0.7-1.fc14: fe_process_frames: Process /usr/bin/pocketsphinx_batch was killed by signal 8 (SIGFPE)
[abrt] pocketsphinx-0.7-1.fc14: fe_process_frames: Process /usr/bin/pocketsph...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pocketsphinx (Show other bugs)
14
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
abrt_hash:aaf2b7b106bf6d4aeb14abfab74...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 10:33 EDT by Richard Ryniker
Modified: 2012-05-03 12:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-03 12:19:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (20.81 KB, text/plain)
2012-05-01 10:33 EDT, Richard Ryniker
no flags Details

  None (edit)
Description Richard Ryniker 2012-05-01 10:33:40 EDT
abrt version: 1.1.18
architecture: x86_64
Attached file: backtrace, 21313 bytes
cmdline: pocketsphinx_batch -hmm /usr/share/pocketsphinx/model/hmm/en_US/hub4wsj_sc_8k -dict /usr/share/pocketsphinx/model/lm/en_US/cmu07a.dic -adcin yes -adchdr 44 -frate 44100 -ctl /home/ryniker/cmd/test_sphinx-control -cepext .wav -hyp /home/ryniker/tmp/sphinx_output
comment: raw audio file, sample rate 44100 ( -frate 44100 ) caused the problem.
component: pocketsphinx
Attached file: coredump, 411873280 bytes
crash_function: fe_process_frames
executable: /usr/bin/pocketsphinx_batch
kernel: 2.6.35.14-106.fc14.x86_64
package: pocketsphinx-0.7-1.fc14
rating: 4
reason: Process /usr/bin/pocketsphinx_batch was killed by signal 8 (SIGFPE)
release: Fedora release 14 (Laughlin)
time: 1335881452
uid: 501

How to reproduce
-----
1.  pocketsphinx_batch  
2.
3.
Comment 1 Richard Ryniker 2012-05-01 10:33:43 EDT
Created attachment 581395 [details]
File: backtrace
Comment 2 Jerry James 2012-05-01 11:32:48 EDT
Thank you for the report, Richard.  Fedora 14 has reached EOL, so there will be no updates.  However, I will try to patch this bug for Fedora 15 and later.

This bug has been reported upstream: https://sourceforge.net/tracker/?func=detail&aid=3522793&group_id=1904&atid=101904.
Comment 3 Nickolay V. Shmyrev 2012-05-03 07:55:19 EDT
Sample rate is configured with -samprate option, not -frate option. Frate options sets feature frame rate. So this is just an incorrect usage of the engine.

I've just committed additional check in pocketsphinx trunk, now it will issue error in the case frate is not correctly configured.

ERROR: "fe_interface.c", line 77: Frame rate 44100 can not be bigger than sample rate 16000.00
Comment 4 Richard Ryniker 2012-05-03 08:30:23 EDT
Thank you.  I thought it likely this was a user error.  The informative message is certainly more valuable than a floating point exception to educate a user.

I tried the failing case on F17, with the same FPE.  Your improvement will help users who make the same error in new environments.
Comment 5 Jerry James 2012-05-03 12:19:08 EDT
Nickolay, thanks for your help.  Richard, I'm going to close this and wait patiently for the next release of pocketsphinx.

Note You need to log in before you can comment on or make changes to this bug.