Bug 817855 - fantasdic crashes before it comes up
fantasdic crashes before it comes up
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fantasdic (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 11:24 EDT by Göran Uddeborg
Modified: 2012-05-06 03:42 EDT (History)
1 user (show)

See Also:
Fixed In Version: fantasdic-1.0-0.11.beta7.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-06 00:52:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2012-05-01 11:24:40 EDT
Description of problem:
When I try to start fantasdic, it crashes immediately, complaining about character encoding.

Version-Release number of selected component (if applicable):
fantasdic-1.0-0.10.beta7.fc17.noarch
ruby-1.9.3.0-9.fc17.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Type on the command line: fantasdic
  
Actual results:
freddi$ fantasdic
/usr/bin/fantasdic:6: warning: variable $KCODE is no longer effective; ignored
/usr/share/rubygems/rubygems/custom_require.rb:36:in `require': /usr/share/ruby/vendor_ruby/fantasdic/translators.rb:8: invalid multibyte char (US-ASCII) (SyntaxError)
/usr/share/ruby/vendor_ruby/fantasdic/translators.rb:8: invalid multibyte char (US-ASCII)
/usr/share/ruby/vendor_ruby/fantasdic/translators.rb:8: syntax error, unexpected $end, expecting ']'
...gundes <dnoway@gmail.com>","Fábio Nogueira <deb-user-ba@ubu...
...                               ^
        from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
        from /usr/share/ruby/vendor_ruby/fantasdic.rb:27:in `<top (required)>'
        from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
        from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
        from /usr/bin/fantasdic:9:in `<main>'

Expected results:
A fantasdic window

Additional info:
My LANG is set to sv_SE.utf8, incase it matters.  Also, I don't know Ruby, but maybe this could be related to the switch to Ruby 1.9 in F17?
Comment 1 Mamoru TASAKA 2012-05-02 12:23:50 EDT
Please try -11 which will be pushed into testing repository.
Comment 2 Fedora Update System 2012-05-02 12:28:45 EDT
fantasdic-1.0-0.11.beta7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fantasdic-1.0-0.11.beta7.fc17
Comment 3 Fedora Update System 2012-05-02 16:33:04 EDT
Package fantasdic-1.0-0.11.beta7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fantasdic-1.0-0.11.beta7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7084/fantasdic-1.0-0.11.beta7.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-05-06 00:52:59 EDT
fantasdic-1.0-0.11.beta7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Göran Uddeborg 2012-05-06 03:42:35 EDT
The new version went to "stable" before I had a chance to test it, so there is not much point for me to add any karma.

But I have tested it now, and can confirm the problem is gone.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.