This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 817889 - boot menu lacks a memory test option when booting EFI computers
boot menu lacks a memory test option when booting EFI computers
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-05-01 13:28 EDT by Chris Murphy
Modified: 2012-05-02 18:34 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 18:34:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Murphy 2012-05-01 13:28:10 EDT
Description of problem:
There is no memory test option in the GRUB menu, when booting Live-Desktop or DVD media on EFI computers.

Version-Release number of selected component (if applicable):
Fedora-17-TC2-x86_64-DVD
Fedora-17.TC2-x86_64-Live-Desktop

How reproducible:
Always

Steps to Reproduce:
1. Boot media on EFI enabled computer.
2. Bypass timeout to get to the main menu.

  
Actual results:
Boot, and Verify and Boot options exist. But no memory test.

Expected results:
Should include a memory test.
Comment 1 Chris Murphy 2012-05-01 13:29:40 EDT
Propose as blocker, based on final release criterion #3:
All release media must include a standalone memory test utility. A boot menu option to launch this utility must be present and must work correctly.
Comment 2 Tim Flink 2012-05-01 17:46:37 EDT
Discussed in the 2012-05-01 blocker bug review meeting. Accepted as a Fedora 17 final blocker as it is a conditional violation of the following final release criterion for EFI systems [1]:

All release media must include a standalone memory test utility. A boot menu option to launch this utility must be present and must work correctly.

[1] https://fedoraproject.org/wiki/Fedora_17_Final_Release_Criteria
Comment 3 Tim Flink 2012-05-01 18:41:57 EDT
Changing component to lorax since the grub menu for the installer ISOs is generated there.
Comment 4 Brian Lane 2012-05-02 18:34:26 EDT
We can't do this. memtest86 doesn't work on EFI systems.

Note You need to log in before you can comment on or make changes to this bug.