Bug 817922 - scanimage -T segfault
scanimage -T segfault
Status: CLOSED DUPLICATE of bug 850826
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
17
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 15:34 EDT by Jeff Layton
Modified: 2014-06-18 03:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 09:41:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"bt full" output from running scanimage -T under gdb (39.08 KB, text/plain)
2012-05-01 15:34 EDT, Jeff Layton
no flags Details

  None (edit)
Description Jeff Layton 2012-05-01 15:34:41 EDT
Created attachment 581453 [details]
"bt full" output from running scanimage -T under gdb

Under F14 and F15, my scanner worked just fine. Since the latest update to
libsane-hpaio-3.12.2-3.fc16.x86_64 however everything that tries to touch
it segfaults.

The previous 3.11 version seems to be fine however so I've downgraded to that for now. I can't be certain that the problem is in libsane-hpaio since there are dependencies on other packages that make it difficult to test in isolation, but it
seems like a reasonable place to start...

The scanner in question is:

device `hpaio:/net/HP_LaserJet_CM1415fnw?zc=NPIC3B49B' is a Hewlett-Packard HP_LaserJet_CM1415fnw all-in-one

A simple way to generate such a segfault is to simply run:

    $ scanimage -T

...attached is a "bt full" from doing that under gdb. I can reproduce this at
will, so let me know if there's other info that I should gather or if you need
me to test a patch (or preferably, a package).
Comment 1 Jeff Layton 2012-08-22 09:41:14 EDT
I'm also seeing this bug in F17, but went ahead and used ABRT to open a bug report with more info. Closing this as a dup of that one.

*** This bug has been marked as a duplicate of bug 850826 ***

Note You need to log in before you can comment on or make changes to this bug.