Bug 817933 - Add back in ability to specificy user and db
Add back in ability to specificy user and db
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello-configure (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jordan OMara
SAM QE List
:
Depends On:
Blocks: sam11-tracker
  Show dependency treegraph
 
Reported: 2012-05-01 16:38 EDT by Bryan Kearney
Modified: 2014-11-09 17:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Changes in the installation and upgrade process disabled the ability to define the candlepin user and database. This update adds --candlepin-db-user and --candlepin-db-name to katello-configure to set the candlepin user and database.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:20:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2012-05-01 16:38:53 EDT
Based on this commit:

https://github.com/bkearney/katello/commit/79c73d5a32bcb58b4bb60962f327e1ecdf27aaa2

We lost the ability to specifiy the user and db for the database for candlepin. This should be added back in.
Comment 1 Jordan OMara 2012-05-03 17:18:16 EDT
merged in https://github.com/Katello/katello/pull/72
& commit 528d11ecc3a67031efb0c7e247328b3355e602bd
Comment 2 Jordan OMara 2012-05-14 15:49:40 EDT
As per conversation with BK: Going to add configuration to katello-configure as well. 

Verification steps:

1. Use katello-configure w/ candlepin-db-username & candlepin-db-password. 
2. Ensure correct setup in postgres
Comment 4 Eric Sammons 2012-06-01 15:50:16 EDT
katello-selinux-0.2.4-1.el6_2.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-common-0.3.2-1.el6_2.noarch
katello-cli-common-0.3.5-2.el6_2.noarch
katello-configure-0.3.7-1.el6_2.noarch
katello-headpin-0.2.12-2.el6_2.noarch
candlepin-0.6.5-1.el6_2.noarch
candlepin-tomcat6-0.6.5-1.el6_2.noarch
katello-glue-candlepin-0.3.2-1.el6_2.noarch
katello-cli-headpin-0.2.2-1.el6_2.noarch
katello-certs-tools-1.1.5-1.el6_2.noarch
katello-headpin-all-0.2.12-2.el6_2.noarch

# katello-configure --deployment=sam --candlepin-db-user=groovy --candlepin-db-name=groovy
Starting Katello configuration
The top-level log file is [/var/log/katello/katello-configure-20120601-154404/main.log]
Creating Katello database user
############################################################ ... OK
Creating Katello database
############################################################ ... OK
Creating Candlepin database user
############################################################ ... OK
Candlepin setup
############################################################ ... OK
Populating Katello database schema
############################################################ ... OK
Initializing Katello data
############################################################ ... OK

# psql -U groovy
psql (8.4.9)
Type "help" for help.

groovy=> 


VERIFIED
Comment 5 sachua 2012-06-14 01:03:12 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Users are unable to specifiy the user and db for the database for candlepin. This updates allows users to specify candlepin user and db using this command:
# katello-configure --deployment=sam --candlepin-db-user=<USERNAME> --candlepin-db-name=<DBNAME>
Comment 6 sachua 2012-06-14 01:05:07 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,2 +1,2 @@
-Users are unable to specifiy the user and db for the database for candlepin. This updates allows users to specify candlepin user and db using this command:
+Users are unable to specifiy the user and db for the database for candlepin. This update allows users to specify candlepin user and db using this command:
 # katello-configure --deployment=sam --candlepin-db-user=<USERNAME> --candlepin-db-name=<DBNAME>
Comment 7 Dan Macpherson 2012-06-15 01:28:06 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,2 +1 @@
-Users are unable to specifiy the user and db for the database for candlepin. This update allows users to specify candlepin user and db using this command:
+Changes in the installation and upgrade process disabled the ability to define the candlepin user and database. This update adds --candlepin-db-user and --candlepin-db-name to katello-configure to set the candlepin user and database.-# katello-configure --deployment=sam --candlepin-db-user=<USERNAME> --candlepin-db-name=<DBNAME>
Comment 9 errata-xmlrpc 2012-06-20 11:20:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1021.html

Note You need to log in before you can comment on or make changes to this bug.