Bug 817938 - [RFE] Allow Columns in Tables to be Sortable
[RFE] Allow Columns in Tables to be Sortable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
: FutureFeature
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-05-01 16:48 EDT by Matt Reid
Modified: 2013-01-07 22:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:51:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-05-01 16:48:32 EDT
Description of problem:
Most tables users encounter allow the user to specify how they are sorted. I think our tables could benefit from supporting this, throughout all of the GUI.

This would let users have more control over the display of data, and give them more tools to find what they're looking for quickly and in the manner they want to. It would also let users know at a glance how the table is currently arranged.

I know Nautilus supports this, my hope is it would be a trivial change code-wise.
Comment 1 Alex Wood 2012-05-14 17:22:36 EDT
commit eb6c43038289ead3246e3bdd76fa817ddfa95d9f
Author: Alex Wood <awood@redhat.com>
Date:   Fri May 11 23:50:58 2012 -0400

    817938: Make columns in subscription-manager tables sortable.

This commit makes the following columns sortable:
  My Installed Software:
    - Product
    - Version
    - Arch
    - Status
    - Start Date
    - End Date
  My Subscriptions:
    - Subscription
    - End Date
    - Quantity
  All Available Subscriptions:
    - Subscription
    - Type
    - Available Subscriptions

Note that the list above does not include the Quantity column underneath All Available Subscriptions.  This omission was intentional as changing the quantity would cause the column to instantly be resorted taking the row you had selected and suddenly placing it in a different order.  I decided this behavior was disorienting.  If you do want sorting on the Quantity column let me know and I will add it back.
Comment 2 Matt Reid 2012-05-16 10:47:19 EDT
Makes sense, I think that's a fair point. Might be something we change down the road, but from the demo, it sounds like a good idea.
Comment 3 Matt Reid 2012-05-31 10:47:36 EDT
Any chance we can implement this for the table in the Contract Selector dialog too?

Could probably skip Used/Total and Quantity, unless you can sort Used/Total as a percentage, but I would expect to be able to sort Contract Number, Type, Start Date, and End Date.

Being able to sort everything in the last commit is pretty awesome.
Comment 4 Alex Wood 2012-06-15 11:35:05 EDT
commit 49fdd2df8bf486ab2b9189e59434e670eeec7c2a
Refs: 817938, subscription-manager-1.0.2-1-84-g49fdd2d
Author:     Alex Wood <awood@redhat.com>
AuthorDate: Fri Jun 1 15:47:26 2012 -0400
Commit:     Alex Wood <awood@redhat.com>
CommitDate: Wed Jun 6 14:41:34 2012 -0400

    817938: Add sorting to the contract selection table.
Comment 5 Sharath Dwaral 2012-06-21 10:56:33 EDT
Version 

RHEL 5.9
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.4-1.git.1.b28337e.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
python-rhsm-1.0.2-1.git.2.d5c3d05.el5
subscription-manager-firstboot-1.0.4-1.git.1.b28337e.el5
subscription-manager-1.0.4-1.git.1.b28337e.el5
subscription-manager-gui-1.0.4-1.git.1.b28337e.el5

Arch is longer a part of GUI under "My Installed Software"
Except for "Quantity" and "Used/Total" it is sortable on every other attribute

>Moving bug to Verified state
Comment 7 errata-xmlrpc 2013-01-07 22:51:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.