Bug 817960 - Support LVM device stacks
Support LVM device stacks
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.4
All Linux
high Severity medium
: rc
: ---
Assigned To: LVM and device-mapper development team
cluster-qe@redhat.com
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 17:16 EDT by Alasdair Kergon
Modified: 2015-09-30 16:51 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 16:51:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alasdair Kergon 2012-05-01 17:16:55 EDT
With LVM supporting an increasing number of target types, a more-sophisticated way of handling stacks of them than the pure PV-on-LV approach is needed.

Investigate the alternatives and decide.


- An incremental lvconvert-style approach?
  (lots of special cases?)

- A more generic extension to the LVM framework?

VGs inside VGs conceptually (i.e. collapsing the PV-on-LV stack into a single VG)?
- allocate upon 'free' sections of LVs?  tagged?
Comment 2 RHEL Product and Program Management 2012-05-05 00:14:59 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Tom Lavigne 2012-09-07 11:22:50 EDT
This request was evaluated by Red Hat Product Management for 
inclusion in the current release of Red Hat Enterprise Linux.
Since we are unable to provide this feature at this time,  
it has been proposed for the next release of 
Red Hat Enterprise Linux.
Comment 4 Jonathan Earl Brassow 2015-09-30 16:51:11 EDT
We have a handful of stacks which are supported, but generalized stacking will not be supported in rhel6

Note You need to log in before you can comment on or make changes to this bug.