Bug 817982 - computer going to sleep kills audio (snd-hda-intel)
computer going to sleep kills audio (snd-hda-intel)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
alsa first=3.3.2 tested=3.4.3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 20:32 EDT by Trever Adams
Modified: 2013-03-18 15:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-18 15:58:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Alsa info (43.03 KB, application/octet-stream)
2012-07-10 17:07 EDT, Trever Adams
no flags Details

  None (edit)
Description Trever Adams 2012-05-01 20:32:32 EDT
Description of problem:
If my computer goes to sleep, the audio does not come back properly. (CD audio, PCM, it is all dead.) If I kill pulseaudio, rmmod and modprobe snd_hda_intel, things work again.

The two related devices are:
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller

I believe 14.2 is the one in question as RS780 is HDMI, I think.

Version-Release number of selected component (if applicable):
kernel-3.3.2-1.fc16.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Put computer to sleep
2. Wake it up
3. Try to use audio
  
Actual results:
Working audio.

Expected results:
No sound!
Comment 1 Trever Adams 2012-06-24 03:22:38 EDT
Still in F17 kernel-3.4.3-1.fc17.x86_64
Comment 2 Josh Boyer 2012-07-10 13:13:36 EDT
I'm guessing this still happens with 3.4.4-5?  Please attach the output of alsa-info
Comment 3 Trever Adams 2012-07-10 17:07:00 EDT
Created attachment 597427 [details]
Alsa info

The bug is only intermittent I now (mostly gone) for the last kernel or two (particularly the 3.4.4-5).

However, the problem is now is that instead of no audio, it is a hiss that doesn't really go away (sound idle or sond playback). Also, there are ocassional clicks or pops that weren't there before in both idle and playback.
Comment 4 Josh Boyer 2013-03-14 14:15:35 EDT
Is this still a problem with 3.8.2 in updates-testing?
Comment 5 Trever Adams 2013-03-18 15:33:08 EDT
I have only had a chance to test this lightly, but it does seem to fix the problem. Thank you!
Comment 6 Josh Boyer 2013-03-18 15:58:50 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.