Bug 818043 - RFE: csprocessor publish command
RFE: csprocessor publish command
Status: CLOSED WONTFIX
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 01:03 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 07:25:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-05-02 01:03:25 EDT
Consider incorporating the functionality of this script in a csprocessor publish command:

https://svn.devel.redhat.com/repos/ecs/toolkit/csp-additional-tools/publisher/publish

It could be improved by automating the increment of the Edition attribute, and probably a bunch of other checks (like the presence of rhpkg on the system).

It could optionally/eventually take an argument, or the csprocessor.cfg could specify its output target, to enable other publishing mechanisms.



cspclient-0.23.2-1.noarch
OS: Fedora release 17 (Beefy Miracle)

JAVA: java version "1.7.0_b147-icedtea"
OpenJDK Runtime Environment (fedora-2.1.fc17.1-i386)
OpenJDK Client VM (build 22.0-b10, mixed mode)
Comment 1 Joshua Wulf 2012-05-02 01:05:08 EDT
s/Edition/Pubsnumber
Comment 2 Joshua Wulf 2012-05-02 05:02:34 EDT
It would be good if it could check if a build with the pubsnumber already exists, and then increment the pubsnumber until it finds one that is free.
Comment 4 Lee Newson 2012-05-18 07:25:55 EDT
I won't be implementing this as it then makes the CSP bound to internal Red Hat use (or certain systems, atm it just needs publican and skynet which can be used on basically any system). While this is okay for the mean time its not in the long run and not worth the time to be put in for it to just be deleted at a later stage.
Comment 5 Lee Newson 2012-06-07 18:36:20 EDT
*** Bug 829947 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.