Bug 818082 - ssh-copy-id from root to guest_u account causes denial
ssh-copy-id from root to guest_u account causes denial
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Miroslav Vadkerti
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 03:38 EDT by Miroslav Vadkerti
Modified: 2012-06-20 08:34 EDT (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-149.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:34:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Vadkerti 2012-05-02 03:38:24 EDT
Description of problem:
type=SYSCALL msg=audit(1335943641.153:147): arch=c000003e syscall=42 success=no exit=-13 a0=4 a1=7f47acfd11a0 a2=6e a3=1 items=0 ppid=13487 pid=13491 auid=507 uid=507 gid=507 euid=507 
                 suid=507 fsuid=507 egid=507 sgid=507 fsgid=507 tty=(none) ses=2471 comm="sshd" exe="/usr/sbin/sshd" subj=guest_u:guest_r:guest_t:s0 key=(null)
type=AVC msg=audit(1335943641.153:147): avc:  denied  { write } for  pid=13491 comm="sshd" name="log" dev=devtmpfs ino=79941 scontext=guest_u:guest_r:guest_t:s0 
                 tcontext=unconfined_u:object_r:devlog_t:s0 tclass=sock_file

Version-Release number of selected component (if applicable):
selinux-policy-3.7.19-147.el6

How reproducible:
100%

Steps to Reproduce:
1. useradd -Z guest_u testuser
2. passwd testuser
3. ssh-copy-id testuser@localhost
  
Actual results:
Permission denied (ssh-copy-id)/No error msg with ssh. AVC in description.

Expected results:
No denial.

Additional info:
I think something may be missing from the log?
Comment 1 Miroslav Grepl 2012-05-02 04:32:15 EDT
Just try to switch to permissive mode for all AVC msgs. We don't allow guest_t to send log messages.
Comment 2 Miroslav Vadkerti 2012-05-02 05:07:47 EDT
I think it is the only one, though I can recheck
Comment 9 Miroslav Grepl 2012-05-08 14:02:16 EDT
Fixed in selinux-policy-3.7.19-149.el6
Comment 12 errata-xmlrpc 2012-06-20 08:34:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0780.html

Note You need to log in before you can comment on or make changes to this bug.