Bug 818095 - SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from 'getattr' accesses on the file /home/penthium/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/#mail.google.com/settings.sol.
SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from 'getattr' ac...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a039456b0a95781e0f6fc950d2a...
:
: 818109 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 04:29 EDT by penthium2
Modified: 2012-05-02 06:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 06:53:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description penthium2 2012-05-02 04:29:43 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.4-1.fc17.i686.PAE
time:           mer. 02 mai 2012 10:30:00 CEST

description:
:SELinux is preventing /usr/lib/nspluginwrapper/npviewer.bin from 'getattr' accesses on the file /home/penthium/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/#mail.google.com/settings.sol.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/home/penthium/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/#mail.google.com/settings.sol default label should be mozilla_home_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /home/penthium/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/#mail.google.com/settings.sol
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that npviewer.bin should be allowed getattr access on the settings.sol file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep npviewer.bin /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_dir_t:s0
:Target Objects                /home/penthium/.macromedia/Flash_Player/macromedia
:                              .com/support/flashplayer/sys/#mail.google.com/sett
:                              ings.sol [ file ]
:Source                        npviewer.bin
:Source Path                   /usr/lib/nspluginwrapper/npviewer.bin
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           nspluginwrapper-1.4.4-7.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-118.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.4-1.fc17.i686.PAE #1 SMP Fri Apr
:                              27 19:18:33 UTC 2012 i686 i686
:Alert Count                   2
:First Seen                    mer. 02 mai 2012 10:23:53 CEST
:Last Seen                     mer. 02 mai 2012 10:23:53 CEST
:Local ID                      8bacee2b-151d-4315-af5f-fd4a6e461919
:
:Raw Audit Messages
:type=AVC msg=audit(1335947033.981:288): avc:  denied  { getattr } for  pid=2386 comm="npviewer.bin" path="/home/penthium/.macromedia/Flash_Player/macromedia.com/support/flashplayer/sys/#mail.google.com/settings.sol" dev="sda6" ino=17039416 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1335947033.981:288): arch=i386 syscall=stat64 success=no exit=EACCES a0=b62212c0 a1=bf8a61d0 a2=4d690ff4 a3=bf8a62ac items=0 ppid=1529 pid=2386 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=npviewer.bin exe=/usr/lib/nspluginwrapper/npviewer.bin subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: npviewer.bin,mozilla_plugin_t,user_home_dir_t,file,getattr
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-05-02 06:52:11 EDT
*** Bug 818109 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-05-02 06:53:24 EDT
You homedir is mislabeled. Please execute

# restorecon -R -v /home/penthium


which will fix labeling.

Note You need to log in before you can comment on or make changes to this bug.