This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 818108 - [AIO] engine-setup: Creation of local storage fails
[AIO] engine-setup: Creation of local storage fails
Status: CLOSED DUPLICATE of bug 823960
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Michael Pasternak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 04:51 EDT by Rami Vaknin
Modified: 2014-01-12 19:37 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 10:16:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rami Vaknin 2012-05-02 04:51:12 EDT
Environment:
ovirt-engine on Fedora 16
ovirt-engine-setup-plugin-allinone-3.1.0_0001-1.8.fc16.x86_64
ovirt-engine-sdk-1.6.2-1.fc16.noarch

Scenario:
1. Run engine-setup which allinone-plugin is installed
2. Choose using vdsm on that machine in the engine-setup wizard and provide an existing empty dir for local storage creation

Result:
Local storage creation on the given path fails

From engine-setup's log:
2012-04-25 11:09:09::INFO::all_in_one_100::287::root:: Adding local storage domain
2012-04-25 11:10:09::ERROR::all_in_one_100::290::root:: Traceback (most recent call last):

    File "/usr/share/ovirt-engine/scripts/plugins/all_in_one_100.py", line 288, in addStorageDomain
        controller.CONF["API_OBJECT"].storagedomains.add(sdParams)
    File "/usr/lib/python2.7/site-packages/ovirtsdk/infrastructure/brokers.py", line 2739, in add
        body=ParseHelper.toXml(storagedomain))
    File "/usr/lib/python2.7/site-packages/ovirtsdk/infrastructure/proxy.py", line 42, in add
        return self.request('POST', url, body, headers)
    File "/usr/lib/python2.7/site-packages/ovirtsdk/infrastructure/proxy.py", line 52, in request
        conn=self.getConnectionsPool().getConnection())
    File "/usr/lib/python2.7/site-packages/ovirtsdk/infrastructure/errors.py", line 96, in __init__
        f_detail = params.parseString(res)
    File "/usr/lib/python2.7/site-packages/ovirtsdk/xml/params.py", line 16624, in parseString
        doc = parsexml_(StringIO(inString))
    File "/usr/lib/python2.7/site-packages/ovirtsdk/xml/params.py", line 70, in parsexml_
        doc = etree_.parse(*args, kwargs)

    File "lxml.etree.pyx", line 2942, in lxml.etree.parse (src/lxml/lxml.etree.c:54187)
    File "parser.pxi", line 1545, in lxml.etree._parseDocument (src/lxml/lxml.etree.c:79661)
    File "parser.pxi", line 1573, in lxml.etree._parseMemoryDocument (src/lxml/lxml.etree.c:79932)
    File "parser.pxi", line 1452, in lxml.etree._parseDoc (src/lxml/lxml.etree.c:78774)
    File "parser.pxi", line 960, in lxml.etree._BaseParser._parseDoc (src/lxml/lxml.etree.c:75389)
    File "parser.pxi", line 564, in lxml.etree._ParserContext._handleParseResultDoc (src/lxml/lxml.etree.c:71739)
    File "parser.pxi", line 645, in lxml.etree._handleParseResult (src/lxml/lxml.etree.c:72614)
    File "parser.pxi", line 585, in lxml.etree._raiseParseError (src/lxml/lxml.etree.c:71955)

XMLSyntaxError: Space required after the Public Identifier, line 1, column 47
...
...
2012-04-25 11:10:09::ERROR::engine-setup::2709::root:: Traceback (most recent call last):

    File "/usr/bin/engine-setup", line 2703, in <module>
        main(confFile)
    File "/usr/bin/engine-setup", line 2494, in main
        runSequences()
    File "/usr/bin/engine-setup", line 2440, in runSequences
        controller.runAllSequences()
    File "/usr/share/ovirt-engine/scripts/setup_controller.py", line 54, in runAllSequences
        sequence.run()
    File "/usr/share/ovirt-engine/scripts/setup_sequences.py", line 152, in run
        step.run()
    File "/usr/share/ovirt-engine/scripts/setup_sequences.py", line 59, in run
        function()
    File "/usr/share/ovirt-engine/scripts/plugins/all_in_one_100.py", line 291, in addStorageDomain
        raise Exception(ERROR_ADD_LOCAL_DOMAIN)

Exception: Error: could not add local storage domain
Comment 1 Michael Pasternak 2012-05-29 10:16:37 EDT

*** This bug has been marked as a duplicate of bug 823960 ***

Note You need to log in before you can comment on or make changes to this bug.