Bug 818119 - p2v does not display the disk device of cciss storage.
p2v does not display the disk device of cciss storage.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-p2v (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Matthew Booth
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 05:29 EDT by Daisy Wu
Modified: 2012-06-20 11:09 EDT (History)
8 users (show)

See Also:
Fixed In Version: virt-p2v-0.8.6-5.20120502.1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:09:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no storage showed for cciss (82.14 KB, image/png)
2012-05-02 05:32 EDT, Daisy Wu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0965 normal SHIPPED_LIVE new package: virt-p2v 2012-06-19 17:12:05 EDT

  None (edit)
Description Daisy Wu 2012-05-02 05:29:58 EDT
Description of Problem:
p2v does not display the disk device of the cciss storage.

Version-Release number of selected component:
virt-v2v-0.8.7-5.el6.x86_64
virt-p2v-0.8.6-4.20120427.1.el6

How reproducible:
Always

Step to Reproduce:
1. Download the virt-p2v iso from brewweb.

2. Install rhel6.2-x86_64 on machine with cciss.
login the os to check disk info:
# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/cciss/c0d0p1     7.7G  2.2G  5.2G  29% /
tmpfs                 3.9G  260K  3.9G   1% /dev/shm

# fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/cciss/c0d0'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/cciss/c0d0: 146.7 GB, 146745262080 bytes
255 heads, 63 sectors/track, 17840 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

           Device Boot      Start         End      Blocks   Id  System
/dev/cciss/c0d0p1               1       17841   143305919+  ee  GPT

# blockdev --getsize64 /dev/cciss/c0d0
146745262080

3. Boot the source machine with virt-p2v from pxe,input the ip and password of conversion server.

4. Check the disk info under fixed storage item.


Actual Results:
no disk device displayed under fixed storage item.

Expected Results:
disk device "cciss/c0d0" displayed under fixed storage item normally.

Additional info:
It works well on build virt-p2v_0.8.6-3.20120425.1.el6.iso, so it is a regression bug.
Comment 2 Daisy Wu 2012-05-02 05:32:35 EDT
Created attachment 581550 [details]
no storage showed for cciss
Comment 4 Matthew Booth 2012-05-02 09:12:30 EDT
Confirmed this bug, and that it's a regression. It was introduced by fa10746132a63333a1eb5e2c0198ba490a5aba56. It's fixed upstream in d6ddbbfbfe754dd99b90ef99a70ffbc84826ba5b.
Comment 5 Matthew Booth 2012-05-02 09:34:11 EDT
Also change 254c47eebf565edea2009ed08b265a7494e4b9aa.
Comment 6 Daisy Wu 2012-05-02 22:08:57 EDT
Comment on attachment 581550 [details]
no storage showed for cciss

changed the type of attachment
Comment 7 Daisy Wu 2012-05-07 03:43:12 EDT
Verified this bug on build virt-p2v-0.8.6-5.20120502.1.el6

Version-Release number of selected component:
virt-v2v-0.8.7-6.el6.x86_64
virt-p2v-0.8.6-5.20120502.1.el6

steps
1. Download the virt-p2v iso from brewweb.
2. Install rhel6.2-x86_64 on machine with cciss.
login the os to check disk info:
# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/cciss/c0d0p1     7.7G  2.2G  5.2G  29% /
tmpfs                 3.9G  260K  3.9G   1% /dev/shm

# fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/cciss/c0d0'! The util
fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/cciss/c0d0: 146.7 GB, 146745262080 bytes
255 heads, 63 sectors/track, 17840 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

           Device Boot      Start         End      Blocks   Id  System
/dev/cciss/c0d0p1               1       17841   143305919+  ee  GPT

# blockdev --getsize64 /dev/cciss/c0d0
146745262080

3. Boot the source machine with virt-p2v from pxe,input the ip and password of
conversion server.

4. Check the disk info under fixed storage item, disk device "cciss/c0d0" checked by default.

5. Click convert button. 

6. Source machine can be converted successfully.

Changed the status to verified.
Comment 8 errata-xmlrpc 2012-06-20 11:09:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0965.html

Note You need to log in before you can comment on or make changes to this bug.