Bug 818134 - '-writeconfig/-readconfig' option need to update in qemu-kvm manpage
Summary: '-writeconfig/-readconfig' option need to update in qemu-kvm manpage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.3
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Michal Novotny
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-02 10:14 UTC by Sibiao Luo
Modified: 2014-02-02 22:38 UTC (History)
16 users (show)

Fixed In Version: qemu-kvm-0.12.1.2-2.313.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 07:34:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed patch to add -readconfig/-writeconfig command line options (2.35 KB, patch)
2012-05-23 16:16 UTC, Michal Novotny
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0527 0 normal SHIPPED_LIVE qemu-kvm bug fix and enhancement update 2013-02-20 21:51:08 UTC

Description Sibiao Luo 2012-05-02 10:14:26 UTC
Description of problem:
Since the '-writeconfig/-readconfig' option has been support in rhel6.3 and will easy to debug, but there is no '-writeconfig/-readconfig' option help doc in qemu-kvm manpage, while exiting in the whitepaper. so we should update it.

Version-Release number of selected component (if applicable):
# uname -r && rpm -q qemu-kvm*
2.6.32-268.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.288.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.# man qemu-kvm | grep writeconfig
  # man qemu-kvm | grep readconfig
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michal Novotny 2012-05-23 16:16:31 UTC
Created attachment 586398 [details]
Proposed patch to add -readconfig/-writeconfig command line options

This is the patch to include -readconfig and -writeconfig command line
options to the QEMU man page. Those commands are useful when using
many devices and/or command line arguments in general to save space
in the QEMU command line.

Michal

Comment 6 mazhang 2012-10-25 11:45:09 UTC
Reproduce on qemu-kvm-0.12.1.2-2.295.el6.x86_64&kernel2.6.32-279.el6.x86_64, and verified on qemu-kvm-0.12.1.2-2.331.el6.x86_64&kernel2.6.32-335.el6.x86_64.
So this bug was fixed.

Comment 7 mazhang 2012-10-25 11:59:10 UTC
Verified this issue on:
qemu-kvm-0.12.1.2-2.331.el6.x86_64
kernel 2.6.32-335.el6.x86_64

The man page output is in follow:
#man qemu-kvm | grep -A4 writeconfig
       <-writeconfig file>
           Write device configuration to file. The file can be either filename
           to save command line and device configuration into file or dash
           "-") character to print the output to stdout. This can be later
           used as input file for "-readconfig" option.

# man qemu-kvm | grep -A4 readconfig
       <-readconfig file>
           Read device configuration from file. This approach is useful when
           you want to spawn QEMU process with many command line options but
           you don’t want to exceed the command line character limit.
...

Comment 10 errata-xmlrpc 2013-02-21 07:34:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html


Note You need to log in before you can comment on or make changes to this bug.