Bug 818141 - New web HTML impacts standalone HTML
New web HTML impacts standalone HTML
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
Unspecified All
unspecified Severity high
: 3.0
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks: 820023
  Show dependency treegraph
 
Reported: 2012-05-02 06:37 EDT by Raphaël Hertzog
Modified: 2012-10-30 23:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:11:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix invalid CSS (1.19 KB, patch)
2012-05-02 06:38 EDT, Raphaël Hertzog
no flags Details | Diff

  None (edit)
Description Raphaël Hertzog 2012-05-02 06:37:23 EDT
With the latest Firefox release, I don't see the background images associated to the Prev/Next navigation links.

It turns out that the associated CSS entry is invalid and is thus dropped.

Please find attached a patch that fixes the CSS.
Comment 1 Raphaël Hertzog 2012-05-02 06:38:16 EDT
Created attachment 581570 [details]
Patch to fix invalid CSS
Comment 2 Jeff Fearn 2012-05-03 01:16:08 EDT
This can also be fixed by reversing the 120% and left/right parameters.

e.g.

- background:  url(../images/stock-go-forward.png) 120% right no-repeat;
+ background:  url(../images/stock-go-forward.png) right 120% no-repeat;

However, looking at this bug reveals that there was some breakage caused when adding the jquery to the new web site output, to the non-website HTML. I'm going to use this bug to track fixing that as well as the next/previous buttons.
Comment 4 Jeff Fearn 2012-07-26 00:54:03 EDT
I fixed the standalone navigation style, no other bugs sighted.
Comment 5 Ruediger Landmann 2012-07-26 21:33:42 EDT
I've just reviewed a sample of 8 books of widely different styles and structures without sighting any weirdness attributable to Publican. Happy to call this verified :)

Note You need to log in before you can comment on or make changes to this bug.