Bug 818155 - RDP clipboard functionality broken
RDP clipboard functionality broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: remmina (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
: 822325 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 06:51 EDT by Pavel Alexeev
Modified: 2012-09-26 01:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 20:07:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2012-05-02 06:51:40 EDT
Description of problem:
After some upgrade (migration from Fedora 16 to 17 happened) clipboard does not functional at all.
It does not work also in xfreerdp, but works in rdesktop.

Version-Release number of selected component (if applicable):
# rpm -qa remmina\*
remmina-plugins-telepathy-1.0.0-1.fc17.x86_64
remmina-plugins-nx-1.0.0-1.fc17.x86_64
remmina-plugins-vnc-1.0.0-1.fc17.x86_64
remmina-plugins-xdmcp-1.0.0-1.fc17.x86_64
remmina-plugins-common-1.0.0-1.fc17.x86_64
remmina-plugins-rdp-1.0.0-1.fc17.x86_64
remmina-1.0.0-1.fc17.x86_64

How reproducible:
Always
Comment 1 Christoph Wickert 2012-05-02 07:48:22 EDT
If it doesn't work in xfreerdp either, then it's in freerdp and not in remmina. Reassigning. I am also adjusting severity to 'medium' as this bug doesn't meet any of the criteria for 'high'.
Comment 2 Pavel Alexeev 2012-05-02 08:35:49 EDT
In fact it is very-very annoying see it broken on all servers after upgrade. Please fix it ASAP.
Comment 3 Mads Kiilerich 2012-05-02 08:41:23 EDT
Work is being done upstream right now to support clipboard. It will probably only be fixed in next major update which it probably isn't feasible to backport to f17.

The best way to get improvements in this area is to get involved upstream with testing and other contributions.
Comment 4 Pavel Alexeev 2012-05-02 08:45:39 EDT
This was work normal on 0.9.3 version long time ago. If it is broken now it is regression. Do you report it upstream? Could you please provide link on bug to track fix and try build from SCM?
Comment 5 Mads Kiilerich 2012-05-02 09:39:05 EDT
Upstream is a young project with more focus on moving fast and adding features than being stable. 1.0 was a major rewrite with a license change and in general a big step forward - but also some code that had to be removed and thus some regressions. If an older version works better for you then I recommend somehow using that version instead.

No, I do not report this upstream, but we can keep this bug open until the next upstream release arrive in Fedora.
Comment 6 Pavel Alexeev 2012-05-02 12:31:52 EDT
xfreerdp with option "--plugin cliprdr" work. Is it possible set for xfreerdp
or  remmina to set this option by default for all rdp connections?
Comment 7 Mads Kiilerich 2012-05-02 12:45:09 EDT
Ok, I haven't used clipboard myself. If you say it doesn't work then I trust you, and if you say it works then I also trust you.

AFAIK there is no default settings in xfreerdp. Just create a wrapper sh script with the options you want.

Anyway, if you say it works in xfreerdp but not in remmina then we are back to remmina. I guess there is a checkmark somewhere that enable it. Otherwise it might be something that should be fixed in upstream remmina.
Comment 8 Pavel Alexeev 2012-05-02 13:36:53 EDT
(In reply to comment #7)
> Ok, I haven't used clipboard myself. If you say it doesn't work then I trust
> you, and if you say it works then I also trust you.
Thank you :)
Now I known what it does not work by default, but work with explicit load the plugin cliprdr. Sorry for the noise, that solution found in Internet afte bug submission.

> AFAIK there is no default settings in xfreerdp.
I also does not found that.
> Just create a wrapper sh script
> with the options you want.
It may be workaround. I'll try it.
>
> Anyway, if you say it works in xfreerdp but not in remmina then we are back to
> remmina. I guess there is a checkmark somewhere that enable it. Otherwise it
> might be something that should be fixed in upstream remmina.
I found in remmina only option to disable it, and by default it unchecked. I've try also set it but with no success.
Comment 9 Pavel Alexeev 2012-05-02 13:47:07 EDT
It seams remmina does not use xfreerdp executable itself.

Meantime bug is reported upstream: https://github.com/FreeRDP/Remmina/issues/13
Comment 10 Pavel Alexeev 2012-05-07 12:31:02 EDT
Upstream bug open more than 3 month.

But there Debian (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=659755) and Ubuntu bug already open (https://bugs.launchpad.net/ubuntu/+source/remmina/+bug/937522). In last reports patch fixes issue. Could you please port patch into Fedora?
Comment 11 Christoph Wickert 2012-05-07 12:43:33 EDT
Show me the patch please. Has it ever been submitted upstream?
Comment 13 Pavel Alexeev 2012-05-07 13:44:54 EDT
I don't known nothing about upstream reporting except provided before stalled bug. You may do that if think it have worth.
Comment 14 Christoph Wickert 2012-05-21 05:22:02 EDT
*** Bug 822325 has been marked as a duplicate of this bug. ***
Comment 15 Pavel Alexeev 2012-05-28 05:19:22 EDT
Upstream bug closed. Could you please build new remmina version from master branch with hope it fixed now?
Comment 16 Fedora Update System 2012-06-01 11:22:08 EDT
remmina-1.0.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/remmina-1.0.0-2.fc17
Comment 17 Fedora Update System 2012-06-01 23:54:20 EDT
Package remmina-1.0.0-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing remmina-1.0.0-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8759/remmina-1.0.0-2.fc17
then log in and leave karma (feedback).
Comment 18 Cott Lang 2012-06-02 08:16:30 EDT
The update does not appear to fix it for me.
Comment 19 Pavel Alexeev 2012-06-02 14:04:05 EDT
You hurry post update. It also does not work for me.
Comment 20 Jean-Louis Dupond 2012-06-02 17:30:56 EDT
"Does not work" does not contain alot of information ...

Could you tell me what doesn't work exactly?
Also if it crashes, please send me a backtrace (preferred with debug symbols installed).

If it doesn't crash, please start remmina in console, and post me the messages dumped.
This as the fc version includes a patch with debug information still printed.

Only with this information the feedback can be used!

Thanks
Jean-Louis
Comment 21 Christoph Wickert 2012-06-02 17:36:11 EDT
(In reply to comment #20)
> Also if it crashes, please send me a backtrace (preferred with debug symbols
> installed).

You can find a backtrace of the crash in bug 827756 and the patches I cherry-picked on top of 1.0.0 at http://pkgs.fedoraproject.org/gitweb/?p=remmina.git;a=commit;h=8a5eb05ef585
Comment 22 Cott Lang 2012-06-02 17:52:30 EDT
Jean-Louis, this is a bug about RDP clipboard functionality. I think it is reasonable to interpret "it does not fix it" as the new version not fixing the clipboard problem.

It otherwise appears to work as well as the earlier version.

Thank you for your efforts.
Comment 23 Pavel Alexeev 2012-06-02 21:02:18 EDT
(In reply to comment #20)
> "Does not work" does not contain alot of information ...

Sorry, off course.

Just after start new version and try copy short text on remote machine: https://bugzilla.redhat.com/show_bug.cgi?id=719032

Meantime it now working around 10 minutes. So it progress in any case.
Comment 24 Fedora Update System 2012-06-03 19:28:51 EDT
Package remmina-1.0.0-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing remmina-1.0.0-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8759/remmina-1.0.0-3.fc17
then log in and leave karma (feedback).
Comment 25 Fedora Update System 2012-06-08 20:07:09 EDT
remmina-1.0.0-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.