Bug 818163 - SElinux is preventing /usr/libexec/totem-plugin-viewer from 'create' accesses on the directory .pki from firefox
SElinux is preventing /usr/libexec/totem-plugin-viewer from 'create' accesses...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 07:07 EDT by Filip Skola
Modified: 2016-05-05 00:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.10.0-121.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 00:22:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Skola 2012-05-02 07:07:33 EDT
Version-Release number of selected component (if applicable):
selinux-policy-3.10.0-118.fc17.noarch

How reproducible: the first time I tried to open the page on a installed system, but always on fresh install

Steps to Reproduce:
1. run firefox
2. open a webpage that needs a plugin to display correctly (http://blog.mozilla.org worked for me)
  
Actual results: avc denial
Expected results: no avc denial
Comment 1 Daniel Walsh 2012-05-02 09:39:34 EDT
This would require us to allow mozilla_plugin_t to create home_cert_t. Is there value in blocking plugins from writing to cert content?
Comment 2 Daniel Walsh 2012-05-02 09:46:01 EDT
Miroslav can you try this in permissive mode to see what mozilla_plugin_t writes to the ~/.pki directory.
Comment 3 Miroslav Grepl 2012-05-03 04:21:06 EDT
Ok, I see

# ls -lZ /home/mgrepl/.pki/nssdb
#

and the following AVC

avc: denined { create } for pid=1737 comm="totem-plugin-vi" name=".pki" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dir
Comment 4 Daniel Walsh 2012-05-03 10:04:20 EDT
Ok I am going to allow it.

Fixed in selinux-policy-3.10.0-121.fc17

Although I am not thrilled with the idea.
Comment 5 Miroslav Grepl 2012-05-04 11:35:14 EDT
Ok. 

Filip,
good catch.
Comment 6 Fedora Update System 2012-05-04 15:53:13 EDT
selinux-policy-3.10.0-121.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-121.fc17
Comment 7 Fedora Update System 2012-05-04 18:17:00 EDT
Package selinux-policy-3.10.0-121.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-121.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7313/selinux-policy-3.10.0-121.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-05-08 00:22:49 EDT
selinux-policy-3.10.0-121.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.