Bug 818168 - The /etc/init.d/bmc-watchdog script does not store PID in the PIDFILE
The /etc/init.d/bmc-watchdog script does not store PID in the PIDFILE
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: freeipmi (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ales Ledvinka
Branislav Blaškovič
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 07:19 EDT by Petr MOTEJLEK
Modified: 2016-09-20 00:32 EDT (History)
4 users (show)

See Also:
Fixed In Version: freeipmi-1.2.1-1
Doc Type: Bug Fix
Doc Text:
Cause: Neither the bmc-watchdog daemon nor it's startup script did write pid into the pidfile. Consequence: Tools that are still relying on the missing value did not work reliably. Fix: Rebase to version of freeipmi 1.2.1 added the write. Result: PID file contains the PID
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 06:57:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr MOTEJLEK 2012-05-02 07:19:51 EDT
Description of problem:

Although the /etc/init.d/bmc-watchdog script defines a variable named PIDFILE
which points to /var/run/bmc-watchdog.pid when executing the script with the start parameter, the PIDFILE does not even get created (nor does it contain the actual PID for that matter).

At http://pastebin.com/AMPdPgDP it is possible to see what I did to make the script store the PID (lines 44 and 45) inside the PIDFILE. I don't think this is the correct approach (as I would think that the daemon function that gets called fron the script should be responsible for storing the PID). Also I would like to point out that storing the PID is not possible using the bmc-watchdog utility by itself (it does not have any command-line option for storing the PID in a PIDFILE).

Version-Release number of selected component (if applicable):
freeipmi-bmc-watchdog.x86_64 0.7.16-3.el6
Comment 2 RHEL Product and Program Management 2012-09-07 01:11:49 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Petr MOTEJLEK 2012-09-12 15:20:46 EDT
Hello Aleš,

As proposed in the message from the RHEL Product and Program Management I would like to have this feature scheduled to be released as soon as possible. Could you please look into this and take this request further down the road?

Thanks
Comment 4 Ales Ledvinka 2012-09-18 08:29:05 EDT
Thank you for taking the time to enter a bug report with us. We appreciate the feedback and look to use reports such as this to guide our efforts at improving our products. That being said, this bug tracking system is not a mechanism for requesting support, and we are not able to  guarantee the timeliness or suitability of a resolution.

If this issue is critical or in any way time sensitive, please raise a ticket through your regular Red Hat support channels to make certain  it receives the proper attention and prioritization to assure a timely resolution. 

For information on how to contact the Red Hat production support team, please visit:

https://www.redhat.com/support/process/production/#howto
Comment 7 errata-xmlrpc 2013-11-21 06:57:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1640.html

Note You need to log in before you can comment on or make changes to this bug.