Bug 818169 - no console with spice-gtk 0.12.1 and spice/qxl setup
no console with spice-gtk 0.12.1 and spice/qxl setup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spice-gtk (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marc-Andre Lureau
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 07:23 EDT by Freddy Willemsen
Modified: 2013-05-13 15:10 EDT (History)
5 users (show)

See Also:
Fixed In Version: spice-gtk-0.12-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 10:03:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Freddy Willemsen 2012-05-02 07:23:26 EDT
Description of problem:
When using virt-manager with a guest setup with display set to spice and video set to QXL the console does not show anything, only a message "Connecting to graphical console for guest". When switching video to cirrus for example, only a black screen appears. Setting display to VNC does work.

Version-Release number of selected component (if applicable):
0.12.1

How reproducible:
Update spice-gtk (and dependencies) to 0.12.1

Steps to Reproduce:
1. Create a KVM guest in virt-manager
2. Choose spice for display
3. Choose QXL for video
  
Actual results:
"Connecting to graphical console for guest"

Expected results:
The graphical console

Additional info:
When downgrading to 0.11-4, all is well again.
Comment 1 Marc-Andre Lureau 2012-05-02 07:32:10 EDT
Argh, I missed this case when Daniel rewrote the URI parser:

(virt-manager:6024): GSpice-WARNING **: Missing port or tls-port in spice URI 'spice://localhost?port=5900'
Comment 2 Marc-Andre Lureau 2012-05-02 08:04:28 EDT
Patch sent to Spice ML.
Comment 3 Freddy Willemsen 2012-05-02 09:09:44 EDT
I figured it had to be something relatively easy to fix. Thanks for the quick response. Anxiously awaiting the fixed packages ...
Comment 4 Marc-Andre Lureau 2012-05-02 10:03:21 EDT
Fix in:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4044748
Comment 5 Freddy Willemsen 2012-05-02 11:15:25 EDT
Confirmed, works like a charm!
Comment 6 Fedora Update System 2012-05-04 14:46:05 EDT
spice-gtk-0.12-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/spice-gtk-0.12-2.fc17
Comment 7 Fedora Update System 2012-05-10 07:36:34 EDT
spice-gtk-0.12-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/spice-gtk-0.12-3.fc17
Comment 8 Fedora Update System 2012-05-26 03:09:48 EDT
spice-gtk-0.12-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 deesto 2013-05-13 15:02:42 EDT
This seems to be a problem again in Fedora 19 alpha: the same graphics settings (which are the default) result in a black virt guest display and a runaway virt process that pins 100% of the number of allocated cores.
Comment 10 Marc-Andre Lureau 2013-05-13 15:10:20 EDT
(In reply to comment #9)
> This seems to be a problem again in Fedora 19 alpha: the same graphics
> settings (which are the default) result in a black virt guest display and a
> runaway virt process that pins 100% of the number of allocated cores.

I suggest you open a bug to the appropriate client for further triaging, please give more details! and try to get a backtrace of the 100% cpu process to see where it is spinning. and perhaps some log would be useful too.

Note You need to log in before you can comment on or make changes to this bug.