This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 818181 - [Mellanox 6.4 Feature]: update libmlx4 to support SRIOV
[Mellanox 6.4 Feature]: update libmlx4 to support SRIOV
Status: CLOSED DUPLICATE of bug 756399
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libmlx4 (Show other bugs)
6.4
All Linux
unspecified Severity high
: beta
: 6.3
Assigned To: Doug Ledford
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 07:50 EDT by Vladimir Sokolovsky
Modified: 2013-11-21 15:02 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 756399
Environment:
Last Closed: 2012-10-14 13:14:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Sokolovsky 2012-05-02 07:50:03 EDT
+++ This bug was initially created as a clone of Bug #756399 +++

+++ This bug was initially created as a clone of Bug #756147 +++

Created by Vladimir Sokolovsky to track Mellanox 6.4 code required to SRIOV support

1.  Feature Name:  Short, descriptive, unique name
	Request for updated libmlx4 user space library

2.  Description:  Request for updated libmlx4 user space library

Architectures (mark all that apply) 
32-bit x86   X
64-bit AMD64/Intel EM64T   X

 Dependencies: 
 External links: 
 Priority (H,M,L):  High
 Target Releases: 
 Target Release Date: 
 Drivers or hardware dependency:  
 Target Kernel: 

3. 	Business Justification:
a. Why is this feature needed?  To support updates from Mellanox
b. What hardware does this enable?  Mellanox SRIOV support
c. Forecast, volume or high end platform?  
d. Any configuration info? 
e. When needed? For RHEL 6.4
f. Are there other dependencies (drivers). libibverbs

4. 	Status: 
a. Is code accepted upstream? 
         Planned for June submission 
    If so, what version or patch? 

5. Hardware to Red Hat?
         Yes.
    
6. Partner management contact, email, phone, chat 
         Larry Troan <ltroan@redhat.com>

7. Partner technical contact, email, phone, chat 
         Vladimir Sokolovsky <vlad@mellanox.co.il> (Israel)

8. Partner Testing: Mellanox to test driver during beta

--- Additional comment from ltroan@redhat.com on 2011-11-23 07:48:07 EST ---

Adding IBM Confidential Group as their bug 516705 is actually 3 drivers:
- mlx4_core
- mlx4_en
- mlx4_ib

plus the libmlx4 library.

--- Additional comment from jjarvis@redhat.com on 2012-01-10 12:20:53 EST ---

This enhancement request was evaluated by the full Red Hat Enterprise Linux
team for inclusion in a Red Hat Enterprise Linux minor release.   As a result
of this evaluation, Red Hat has tentatively approved inclusion of this feature
in the next Red Hat Enterprise Linux Update minor release.   While it is a goal
to include this enhancement in the next minor release of Red Hat Enterprise
Linux, the enhancement is not yet committed for inclusion in the next minor
release pending the next phase of actual code integration and successful Red
Hat and partner testing.

--- Additional comment from dledford@redhat.com on 2012-02-29 08:54:08 EST ---

Or,Vlad: Is there a specific version of libmlx4 that supports SRIOV?  I haven't seen any SRIOV patches in Roland's libmlx4 (he seems to be a bit out of date, there isn't a release with XRC support either even though it's in the kernel now).

Come to look at it..it appears XRC support has landed in the kernel, but not in either libibverbs or libmlx4...ditto SRIOV.  Do you guys have a specific patch set you are targetting for inclusion in the user space packages?

--- Additional comment from ogerlitz@mellanox.com on 2012-03-01 15:40:13 EST ---

(In reply to comment #5)
> Is there a specific version of libmlx4 that supports SRIOV?  I haven't
> seen any SRIOV patches in Roland's libmlx4 

Doug,

To sync, the SRIOV code that was submitted upstream only brings the Mellanox mlx4 driver to support SRIOV for plain Ethernet networking, that is IB and nor IBoE (RoCE) are supported in the upstream code with SRIOV. So in that respect, IB/IBoE SRIOV aren't for RHEL6.3, as for libmlx4, I don't think we patch it to support SRIOV but I will check
Comment 2 Doug Ledford 2012-10-14 13:14:05 EDT

*** This bug has been marked as a duplicate of bug 756399 ***

Note You need to log in before you can comment on or make changes to this bug.