Bug 818184 - input check is needed for hardware 'category' field
input check is needed for hardware 'category' field
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.5
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Greg Nichols
Guangze Bai
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-05-02 07:59 EDT by Guangze Bai
Modified: 2015-02-08 16:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
commandLineUI patch requiring answer to be one of the options (984 bytes, patch)
2012-05-15 11:08 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Guangze Bai 2012-05-02 07:59:31 EDT
Description of problem:

[snip]
Please verify the hardware product information:
    vendor:     
    make:        
    model:                 
    product-url:        
    category (Desktop/Workstation|Laptop|Component/Peripheral|Server) 17
...

# cat /var/v7/certification.xml
<certification-test v7-version='1.5' v7-release='22'>
  <hardware>
    <arch>x86_64</arch>
    <model>
    </model>
    <make>
    </make>
    <vendor>
    </vendor>
    <product-url>
    </product-url>
    <category>17</category>        <------
  </hardware>


Version-Release number of selected component (if applicable):
v7-1.5-22

How reproducible:
always

Expected results:
similar to this,
[snip]
What certification is this system being tested for? (new|existing|none) abc
response: abc
Please enter one of the following: new | existing | none
Comment 1 Greg Nichols 2012-05-15 11:08:58 EDT
Created attachment 584687 [details]
commandLineUI patch requiring answer to be one of the options
Comment 5 Caspar Zhang 2012-06-04 04:06:08 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 7 errata-xmlrpc 2012-06-05 17:37:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.