Bug 818189 - List service-level for invalid org displays “ERROR: The service-level command is not supported by the server. ”
List service-level for invalid org displays “ERROR: The service-level command...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-05-02 08:13 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:57:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandey 2012-05-02 08:13:10 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
3/3

Prerequisites : 
Client with following subscription-manager rpm.
Candlepin : onpremises server. 

Steps to Repro : 
Register client to candlepin using testuser1 with admin org .
List service list for invalid org ie : 
root@storm ~]# subscription-manager service-level --list --org 000000000

Expected Result : 
Message should display for invalid org.

Actual Result : 
[root@storm ~]# subscription-manager service-level --list --org 000000000
ERROR: The service-level command is not supported by the server.


[root@dhcp201-176 product]# subscription-manager service-level --list --org admin
+-------------------------------------------+
               Available Service Levels
+-------------------------------------------+
Standard
None
Premium
[root@dhcp201-176 product]# subscription-manager service-level --list --org admin123
ERROR: The service-level command is not supported by the server.
[root@dhcp201-176 product]# 

got same issue with stage 

[root@storm ~]# subscription-manager identity
Current identity is: a13f4698-0d98-4d15-8539-f592d32efb8f
name: storm.idm.lab.bos.redhat.com
org name: Anonymous User
org id: 8a99f981370984da0137098639790022
[root@storm ~]# subscription-manager service-level --list --org 1234567
ERROR: The service-level command is not supported by the server.
Comment 2 William Poteat 2012-05-02 12:50:04 EDT
master commit 701b271be0c115838d75583f930d592bfaca61a0

RHEL 6.3 commit 59ac1bfab8159e06f444c15384f72448932553ab
Comment 4 Shwetha Kallesh 2012-05-09 05:44:11 EDT
Verified

RPM used:
[root@skallesh product]# rpm -qa| grep subscription-manager
subscription-manager-debuginfo-0.99.16-1.el6.x86_64
subscription-manager-firstboot-0.99.17-1.git.0.ba3d75c.el6.x86_64
subscription-manager-0.99.17-1.git.0.ba3d75c.el6.x86_64
subscription-manager-migration-0.99.17-1.git.0.ba3d75c.el6.x86_64
subscription-manager-gnome-0.99.17-1.git.0.ba3d75c.el6.x86_64
subscription-manager-migration-data-1.12.1.8-1.git.0.c91a246.el6.noarch



On stage:

[root@skallesh ~]# subscription-manager service-level --list --org 1234
Organization with id 1234 could not be found

Onpremises:

[root@skallesh product]# subscription-manager service-level --list --org 12wef
Organization with id 12wef could not be found.
Comment 6 errata-xmlrpc 2012-06-20 08:57:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.