Bug 8182 - dial problem with RH PPP dialer
dial problem with RH PPP dialer
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Depends On:
  Show dependency treegraph
Reported: 2000-01-04 20:40 EST by biplane
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-12-13 21:00:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description biplane 2000-01-04 20:40:18 EST
I set up an account with a modem in the dialup configuration tool in
version 6.1 of the Redhat software.  When I run the debug, the program
finds the modem, and it dials up with it.  Then, when I run RH PPP dialer,
and click "ok" to start the connection, under the "Waiting to connect..."
box, the only thing that happens is a flurry of hard drive activity for
how ever long you let it go(I let it go for an hour one time).  It does
not find the modem or do anything but make hard drive noise.  Also, under
the configuration tool, if you delete a modem, close the program, and re-
open it, the modem is back again.  If you delete an account, and make a
new one with the same name, it will not let you and says that you already
have that account although you have deleted it(It never reappears like the
modem will).  I downloaded the rp3 rpm update, and followed the
instructions and installed it, restarted the computer, and it now allows
me to add a modem without it crashing the program upon clicking the "Add"
button, but it still will not dial; the same problem occurs when you try
to connect.  I also downloaded the ppp update which did nothing.  Finally,
which is more confusing, is the fact that I had Redhat installed (6.1) and
could dial up just fine until I installed another distribution of Linux on
my machine.  Then, when I went back to RH because I liked it better, I was
unable to connect ever again to the internet.
 I have a computer with an AMD K-6, 200 MHz processor and a Cirruslogic
33.6 modem.
Comment 1 Nalin Dahyabhai 2000-02-07 14:57:59 EST
Please try this using the versions of initscripts, ppp, rp3, and wvdial from
Raw Hide (ftp://ftp.redhat.com/pub/rawhide/i386/RedHat/RPMS/), which fix
several bugs that don't quite warrant an errata release just yet, particularly
problems with setups that work better in debug mode than in normal modes.
Comment 2 a.m 2000-03-03 09:41:59 EST
I've installed the packages you suggested from the rawhide
distribution, and my problem got worse.  Before, I used to
get a "Failed to activate" warningBox when pppd *did* actually
connect; now, rp3 dies with a fatal crash instead.

What bugs me most is that everything used to work just fine
until one day I happened to click on "Configure PPP..." (I
assume that runs rp3-config), when everything started to go
down the pipes.  Why?!?

BTW, I am using chat and usernetctl instead, which work without
a glitch.  I don't really *need* the rp3 eye-candy, but if it did
work, I'd probably use it.

Hmm...  I've just tried again after reboot and I get the same
"Failed to activate" box as before.  Here's the few lines that
get written to /var/log/messages almost indefinitely (well, until
you acknowledge the "warning"), which is probably the cause for the
flury of hard drive activity other users have been reporting...
Gtk-WARNING **: invalid cast from `GnomeMessageBox' to `GtkProgressBar'

Gtk-CRITICAL **: file gtkprogressbar.c: line 751 (gtk_progress_bar_update): asse
rtion `GTK_IS_PROGRESS_BAR (pbar)' failed.
Comment 3 a.m 2000-03-03 09:56:59 EST
Oops!  I lied.  Those messages got printed on stderr.
I got confused, because I was watching the progress of
pppd/chat through "tail -f /var/log/messages".  Sorry.

Nevertheless, there are a few variations of the above
warnings that I've noticed since, such as

Gtk-WARNING **: invalid cast from `(unknown)' to `GtkProgressBar'

Gtk-WARNING **: invalid unclassed pointer in cast to `GtkProgressBar'

The Gtk-CRITICAL errors in between are always the same.
Comment 4 Nalin Dahyabhai 2000-03-06 13:09:59 EST
The error messages related to bad casts with the progress bar should be
fixed in version 1.0.7-3 in Raw Hide -- I distinctly remember fixing them.
Which versions of ppp, initscripts, wvdial, and rp3 do you have installed?
Comment 5 Alan Cox 2002-12-13 21:00:09 EST
No answer in two years

Note You need to log in before you can comment on or make changes to this bug.