Bug 818208 - samba-3.6.5-85.fc17.1: can't find libwclient.so.0
samba-3.6.5-85.fc17.1: can't find libwclient.so.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Andreas Schneider
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 09:05 EDT by Jonathan Kamens
Modified: 2012-10-26 12:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-26 12:27:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2012-05-02 09:05:09 EDT
May  2 09:01:29 jik2 smbd[4195]: /usr/sbin/smbd: error while loading shared libraries: libwbclient.so.0: cannot open shared object file: No such file or directory
Comment 1 Jonathan Kamens 2012-05-02 09:09:17 EDT
It would seem that samba needs a dependency on libwbclient.
Comment 2 Simo Sorce 2012-05-02 09:33:24 EDT
Can you tell what version of libwbclient package do you have ?
Comment 3 Jonathan Kamens 2012-05-02 10:08:18 EDT
I didn't have _any_ version of libwbclient. That's the point -- the samba packages don't tell yum that libwbclient is needed.

Now that I've installed it manually, yum is happy to let me remove it without flagging it as a dependency issues and forcing samba packages to be removed as well:

jik2:~!999$ sudo yum remove libwbclient
[sudo] password for jik: 
Loaded plugins: changelog, downloadonly, fastestmirror, langpacks, presto,
              : refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package libwbclient.x86_64 1:3.6.5-85.fc17.1 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package         Arch       Version                  Repository            Size
================================================================================
Removing:
 libwbclient     x86_64     1:3.6.5-85.fc17.1        @updates-testing      50 k

Transaction Summary
================================================================================
Remove  1 Package

Installed size: 50 k
Is this ok [y/N]:
Comment 4 Alexander Bokovoy 2012-05-02 10:48:43 EDT
What samba-1:3.6.5-85.fc17.1.x86_64 requires is libwbclient.so.0()(64bit). The latter is provided by libwbclient-1:3.6.5-85.fc17.1.x86_64 so yum should be able to solve the dependency easily.

You can check yourself:
samba -- http://koji.fedoraproject.org/koji/rpminfo?rpmID=3087763
libwbclient -- http://koji.fedoraproject.org/koji/rpminfo?rpmID=3087771
Comment 5 Jonathan Kamens 2012-05-02 11:06:01 EDT
$ rpm -q --whatprovides 'libwbclient.so.0()(64bit)'
samba4-libs-4.0.0-43alpha18.fc17.x86_64
libwbclient-3.6.5-85.fc17.1.x86_64
$ rpm -ql samba4-libs | grep libwbclient
/usr/lib64/samba/libwbclient.so.0
/usr/lib64/samba/libwbclient.so.0.9
$ rpm -ql libwbclient | grep libwbclient
/usr/lib64/libwbclient.so.0
$ 

There is some confusion here.
Comment 6 Simo Sorce 2012-05-02 17:39:37 EDT
ok we will investigate how to handle this, the issue is in the samba4 packages they should not provide 'libwbclient.so.0()(64bit)' as in the samb4 case libwbclient is a private library.
Comment 7 Peter 2012-05-04 04:11:16 EDT
Hello.
I have the same problem, but on my F16, 32bit !
I am trying to do yum update, but it fails:
------
...
Running Transaction Check
ERROR with transaction check vs depsolve:
libwbclient.so.0 is needed by samba-common-1:3.6.5-85.fc16.i686
libwbclient.so.0 is needed by samba-1:3.6.5-85.fc16.i686
libwbclient.so.0 is needed by libsmbclient-1:3.6.5-85.fc16.i686
libwbclient.so.0 is needed by samba-winbind-clients-1:3.6.5-85.fc16.i686
libwbclient.so.0 is needed by cifs-utils-5.4-1.fc16.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
cifs-utils-5.3-2.fc16.i686 has missing requires of libwbclient.so.0
1:libsmbclient-3.6.4-82.fc16.i686 has missing requires of libwbclient.so.0
1:samba-3.6.4-82.fc16.i686 has missing requires of libwbclient.so.0
1:samba-common-3.6.4-82.fc16.i686 has missing requires of libwbclient.so.0
1:samba-winbind-clients-3.6.4-82.fc16.i686 has missing requires of libwbclient.so.0
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-05-04.09-25.mdBjwb.yumtx

------

uname -a:
Linux notebook 3.3.2-6.fc16.i686.PAE #1 SMP Sat Apr 21 13:02:14 UTC 2012 i686 i686 i386 GNU/Linux

Any help to solve this ?
Thank you. :)
Comment 8 Andreas Schneider 2012-10-26 12:27:28 EDT
This has already been fixed. Please reopen if you're still running into the problem.

Note You need to log in before you can comment on or make changes to this bug.