Bug 818226 - Weird check for null pointer in mirror_abort()
Weird check for null pointer in mirror_abort()
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 09:54 EDT by Pavel Raiskup
Modified: 2013-01-09 19:55 EST (History)
11 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.291.el6
Doc Type: Bug Fix
Doc Text:
No Documentation Needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 07:47:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of added defects in qemu-kvm-0.12.1.2-2.282 (2.22 KB, text/plain)
2012-05-02 09:56 EDT, Pavel Raiskup
no flags Details

  None (edit)
Description Pavel Raiskup 2012-05-02 09:54:24 EDT
Hello,

new Coverity rescan found new potential defect in qemu-kvm.  Look at:

    qemu-kvm-0.12.1.2/block/mirror.c:290 at the function mirror_abort()

There is done check for 's' non-null pointer but on the following line there is
direct dereference.  Note that I don't know what is the purpose of these lines
but This check is really suspicious and at least something goes wrong.

List of added defects is attached.

Pavel

Devel:
  This error is mentioned just as a warning and it depends on you whether
  it will be fixed.  This defect can be not so dangerous and/or not so
  prioritized to be fixed in 6.3 so feel free to move it to 6.4 or close it as
  a NOTABUG if we don't need to fix it at all.

Quality engineering:
  This issue was found by static analysis tool and we can't provide any
  reproducer for it.  We are able to rescan package once this problem is
  fixed.  Please check this as SanityOnly (just check that patches for the
  issues and check if nothing unexpected was added by the commit).  If you
  want to check the new package with Coverity yourself, feel free to use
  covscan tool (https://engineering.redhat.com/trac/CoverityScan/wiki/covscan).
Comment 1 Pavel Raiskup 2012-05-02 09:56:00 EDT
Created attachment 581622 [details]
List of added defects in qemu-kvm-0.12.1.2-2.282

Sorry -- my browser was unable to attach it in one-run.  Pavel
Comment 3 Ademar Reis 2012-05-07 14:43:31 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Documentation Needed
Comment 9 errata-xmlrpc 2012-06-20 07:47:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0746.html

Note You need to log in before you can comment on or make changes to this bug.