Bug 81824 - galeon has faulty package dependency on mozilla
Summary: galeon has faulty package dependency on mozilla
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: galeon
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-14 11:11 UTC by Michael Young
Modified: 2008-05-01 15:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-29 03:22:53 UTC


Attachments (Terms of Use)

Description Michael Young 2003-01-14 11:11:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1) Gecko/20020921
Netscape/7.0

Description of problem:
galeon 1.2.7-0 requires mozilla=1.2.1
mozilla 1.2.1-5 provides mozilla=35:1.2.1-5
A consequence is that rpm refuses to upgrade from mozilla 1.2.1-3 to 1.2.1-5
giving the error
error: Failed dependencies:
        mozilla = 1.2.1 is needed by (installed) galeon-1.2.7-0

Probably galeon should require mozilla=35:1.2.1 though I can't easily test it.

Steps to Reproduce:
1. upgrade mozilla 1.2.1-3 to 1.2.1-5 with galeon-1.2.7-0 installed

Comment 1 Thomas J. Baker 2003-01-23 14:41:42 UTC
Kind of a me too but when I upgrade mozilla from rawhide, I have to remove
galeon first because it needs mozilla = 1.2.1. After removing galeon and
upgrading mozilla, the galeon package installs fine so I'm not quite
sure where the dependency problems are.


Comment 2 Panu Matilainen 2003-01-23 15:18:18 UTC
I'm seeing this too.. The dependencies for both galeon and mozilla look sane for
me, I wouldn't be surprised if this was some sort of quirk in rpm. Something
along lines of "on package install 35:1.2.1-10 == 1.2.1 but on upgrade they're
not considered equal" or something like that. That's purely guessing but would
explain the situation we're seeing at least :-/

Comment 3 Panu Matilainen 2003-01-23 15:20:49 UTC
..one way to find out I guess would be to have an explicit
Provides: %{name} = %{version}
in the mozilla spec, so that there is an exact match for galeons requirement
(without all the epoch and release number stuff)


Comment 4 Jeremy Katz 2003-01-23 16:16:10 UTC
galeon needs to include the epoch of the mozilla package in its Requires

Comment 5 Panu Matilainen 2003-01-23 17:11:44 UTC
I'm still curious.. why does rpm consider the current galeons dependency to
mozilla = 1.2.1 ok when installing but not when upgrading?

Comment 6 Christopher Blizzard 2003-01-29 03:22:53 UTC
Fixed in 1.2.7-2


Note You need to log in before you can comment on or make changes to this bug.