Bug 818246 - authconfig --update/--updateall restarts rpcbind, which forgets all about registered services.
authconfig --update/--updateall restarts rpcbind, which forgets all about reg...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: authconfig (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomas Mraz
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 10:52 EDT by Lars Kellogg-Stedman
Modified: 2014-11-05 08:42 EST (History)
0 users

See Also:
Fixed In Version: authconfig-6.1.12-19.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-05 08:42:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2012-05-02 10:52:38 EDT
Description of problem:

Running "authconfig" with the --update or --updateall flags will, in a NIS environment, restart the "rpcbind" service. This causes rpcbind to forget about all RPC services that have registered with it, which is a particular problem in an NFS environment.  After running authconfig, rpc.statd will no longer be visible to NFS services, so subsequent mount operations will spawn an instance of "rpc.statd --no-notify".

For example, before running authconfig:

  # rpcinfo -p
     program vers proto   port  service
      100000    4   tcp    111  portmapper
      100000    3   tcp    111  portmapper
      100000    2   tcp    111  portmapper
      100000    4   udp    111  portmapper
      100000    3   udp    111  portmapper
      100000    2   udp    111  portmapper
      100007    2   udp    784  ypbind
      100007    1   udp    784  ypbind
      100007    2   tcp    787  ypbind
      100007    1   tcp    787  ypbind
      100024    1   udp    662  status
      100024    1   tcp    662  status

After running authconfig:

  # authconfig --updateall
  Starting rpcbind:                                          [  OK  ]
  Shutting down NIS service:                                 [  OK  ]
  Starting NIS service:                                      [  OK  ]
  Binding NIS service: .                                     [  OK  ]
  # rpcinfo -p
     program vers proto   port  service
      100000    4   tcp    111  portmapper
      100000    3   tcp    111  portmapper
      100000    2   tcp    111  portmapper
      100000    4   udp    111  portmapper
      100000    3   udp    111  portmapper
      100000    2   udp    111  portmapper
      100007    2   udp    880  ypbind
      100007    1   udp    880  ypbind
      100007    2   tcp    883  ypbind
      100007    1   tcp    883  ypbind

At this point, it is necessary to also restart the "nfslock" service in order to re-register rpc.statd with rpcbind:

  # service nfslock restart
  Stopping NFS locking:                                      [  OK  ]
  Stopping NFS statd:                                        [  OK  ]
  Starting NFS statd:                                        [  OK  ]
  # rpcinfo -p
     program vers proto   port  service
      100000    4   tcp    111  portmapper
      100000    3   tcp    111  portmapper
      100000    2   tcp    111  portmapper
      100000    4   udp    111  portmapper
      100000    3   udp    111  portmapper
      100000    2   udp    111  portmapper
      100007    2   udp    880  ypbind
      100007    1   udp    880  ypbind
      100007    2   tcp    883  ypbind
      100007    1   tcp    883  ypbind
      100024    1   udp    662  status
      100024    1   tcp    662  status
Comment 2 Tomas Mraz 2012-05-02 11:48:16 EDT
Can you please report the issue using the regular support channels? http://www.redhat.com/support/

It will help properly prioritizing the fix for the issue.
Comment 3 Lars Kellogg-Stedman 2012-05-02 12:13:17 EDT
I'm not entirely sure what you're asking.  

We've dealt with this problem locally, and I'm not looking for any sort of support.  I'm just trying to be a good citizen, figuring that reporting this bug will prevent it from biting someone else someday.
Comment 4 RHEL Product and Program Management 2012-09-07 01:26:10 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 Lars Kellogg-Stedman 2012-10-11 09:04:15 EDT
I'm marking my own report WONTFIX since it's clear RedHat has no interest in this problem.  Sorry for bothering you.
Comment 6 Lars Kellogg-Stedman 2012-10-11 09:04:41 EDT
Hmmm, maybe I can't do that.
Comment 7 RHEL Product and Program Management 2013-10-13 20:40:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 8 Tomas Mraz 2014-11-05 08:42:18 EST
I believe this bug is already fixed in the current authconfig in RHEL-6

Note You need to log in before you can comment on or make changes to this bug.