Bug 818248 - ovirt-engine-backend [Task Manager]: no task/step is created for create snapshot when running a stateless vm
ovirt-engine-backend [Task Manager]: no task/step is created for create snaps...
Status: CLOSED DUPLICATE of bug 823243
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity high
: ---
: 3.1.0
Assigned To: Yair Zaslavsky
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 11:02 EDT by Dafna Ron
Modified: 2016-02-10 11:57 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 01:13:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log and screen shot (51.49 KB, application/x-gzip)
2012-05-02 11:02 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-05-02 11:02:00 EDT
Created attachment 581640 [details]
log and screen shot

Description of problem:

when running a stateless vm we should have a task for creating the stateless snapshot and a task for running the vm. 
currently the snapshot is not logged in the task manager. 

Version-Release number of selected component (if applicable):

si2.1

How reproducible:

100%

Steps to Reproduce:
1. run a stateless vm
2.
3.
  
Actual results:

no task is created in task manager for snapshot creation

Expected results:

we should see a task for snapshot creation

Additional info:log
Comment 1 Yair Zaslavsky 2012-05-14 07:38:29 EDT
In RunVmCommand.statelessVmTreatment -
When invoking CreateAllSnapshotsFromVM, we should pass an execution context, and not just the compensation context , so the tasks will be created as steps of the run stateless vm job: Under the RunVm execution Step we should add new step of create snapshot which will act as parent step for the snapshot creation steps (i.e - for each createImage).
RunVm.endSuccessfuly should be extended with additional step in case of RunStatlessVm to create a step presenting running VM after snapshots are successfully created.
Comment 2 Yair Zaslavsky 2012-06-22 01:13:56 EDT

*** This bug has been marked as a duplicate of bug 823243 ***

Note You need to log in before you can comment on or make changes to this bug.