Bug 818275 - grubby doesn't preserve quotes in --args= parameter
grubby doesn't preserve quotes in --args= parameter
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grubby (Show other bugs)
6.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Peter Jones
Release Test Team
:
Depends On:
Blocks: 760559
  Show dependency treegraph
 
Reported: 2012-05-02 11:44 EDT by Jan Stodola
Modified: 2017-12-06 06:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 06:46:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2012-05-02 11:44:57 EDT
Description of problem:
grubby doesn't preserve quotes that are part of --args= parameter, see example bellow.

Version-Release number of selected component (if applicable):
grubby-7.0.15-3.el6

How reproducible:
always

Steps to Reproduce:
1. grubby --add-kernel=/boot/kernel  --args="FCP_1='a007 0x500507630503c73d 0x4020400700000000'"  --initrd=/boot/initrd  --make-default --title=install
2. grep FCP /etc/zipl.conf 

Actual results:
        parameters="FCP_1=a007 0x500507630503c73d 0x4020400700000000"

Expected results:
        parameters="FCP_1='a007 0x500507630503c73d 0x4020400700000000'"
Comment 1 RHEL Product and Program Management 2012-05-06 00:03:35 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Jan Kurik 2017-12-06 06:46:09 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.