Bug 818282 - [RFE] Alter List Order of Contract Selector
[RFE] Alter List Order of Contract Selector
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Devan Goodwin
Entitlement Bugs
: FutureFeature
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-05-02 11:53 EDT by Matt Reid
Modified: 2013-01-07 22:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:52:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sorted entitlements on virt (83.59 KB, image/png)
2012-06-21 09:42 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Matt Reid 2012-05-02 11:53:15 EDT
Description of problem:
When we present the contract selector to users, it doesn't look like we tailor it to their system. When it shows on a VM, I get a Physical type offered to me as the first option, instead of a Virtual one. It would be nice if the first one offered was a Virtual type if they're running a VM, as they probably have more virtual entitlements than physical ones (possibly unlimited).
Comment 1 Devan Goodwin 2012-05-31 13:12:42 EDT
Fixed in subscription-manager master: bf7ee031eacbd0a1cac2ff40df94caad04a3cd1b and 8848d0be347548d3b1b4904223d8add09e75b1ba.

Will appear in: subscription-manager-1.0.3-1

Virtual subs are sorted to the top. We can't really get much more fancy than this in terms of determining applicability.
Comment 2 Sharath Dwaral 2012-06-21 09:42:03 EDT
Created attachment 593449 [details]
Sorted entitlements on virt

Version

RHEL 5.9

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.4-1.git.1.b28337e.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
python-rhsm-1.0.2-1.git.2.d5c3d05.el5
subscription-manager-firstboot-1.0.4-1.git.1.b28337e.el5
subscription-manager-1.0.4-1.git.1.b28337e.el5
subscription-manager-gui-1.0.4-1.git.1.b28337e.el5

# subscription-manager facts | grep virt
virt.host_type: kvm
virt.is_guest: True
virt.uuid: 6b040675-645a-f322-8f68-9d9b4757d565

Virtual entitlements are sorted on top on virtual systems by default

Marking verified
Comment 4 errata-xmlrpc 2013-01-07 22:52:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.