Bug 818308 - Recent Fedora kernels does not have SLIP support
Recent Fedora kernels does not have SLIP support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 13:42 EDT by Nils Olav Selåsdal
Modified: 2012-05-05 21:27 EDT (History)
6 users (show)

See Also:
Fixed In Version: kernel-3.3.4-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-05 21:27:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Olav Selåsdal 2012-05-02 13:42:58 EDT
Description of problem:
This kernel: 3.3.2-6.fc16.x86_64 seems to not have SLIP support, it appears it disappeared at some point, as the slip.ko module were present in at least 3.3.2-6.fc16.x86_64.

Please bring it back.


Version-Release number of selected component (if applicable):
3.3.2-6.fc16.x86_64
Comment 1 Justin M. Forbes 2012-05-03 09:54:40 EDT
Sorry about that. SLIP support is scheduled to go away in F17, and got turned off prematurely in F16.  Can you tell us a bit more about how you are using it?
I am turning it back on in F16 for kernel-3.3.4-3.fc16 and newer.
Comment 2 Nils Olav Selåsdal 2012-05-03 10:16:39 EDT
We have several (very) old devices capable of relaying telemetry that we want to consume. These are SLIP capable (or can be used generally as a tty, but no PPP support).

Since this works well, there's no need to replace them. It's a pity if this goes away in F17. Even if SLIP is old technology, that alone should be no reason to remove it.
Comment 3 Justin M. Forbes 2012-05-03 12:22:21 EDT
I think we can turn it on in the next build for F17 as well, though it will be in the kernel-modules-extra package.
Comment 4 Fedora Update System 2012-05-03 17:59:07 EDT
kernel-3.3.4-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.3.4-3.fc16
Comment 5 Fedora Update System 2012-05-04 16:31:32 EDT
Package kernel-3.3.4-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.3.4-3.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7298/kernel-3.3.4-3.fc16
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-05-05 21:27:49 EDT
kernel-3.3.4-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.