Bug 81831 - RH 8.0.92 XFree86 problem w/ montior/video card
RH 8.0.92 XFree86 problem w/ montior/video card
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-14 09:56 EST by Justin Churchey
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-24 10:33:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Churchey 2003-01-14 09:56:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

Description of problem:
I am attempting to install RH 8.0.92 and anaconda comes up scrambled as if the
montior frequency is off.  I'm using a Compaq P50 monitor and an ATI Radeon
(Generic) card.  Both have worked in the past, and I don't understand why 8.0.92
might be doing this.

I know anaconda well enough to attempt to upgrade my RH 8.0 installation, but
after the installation is done, X does not want to start.  I would attempt
another upgrade again, but i have data I would like to keep.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Put RH 8.0.92 Installation CD in
2.Boot computer from CD-RW drive
3.
    

Actual Results:  Cannot make out installation screen.

Expected Results:  The smooth appearance of anaconda followed by a successful
upgrade

Additional info:

Dual AMD Athlon MP 2100+
1 GB DDR RAM
ATI Radeon card 4X AGP (32MB)
Comment 1 Michael Fulbright 2003-01-14 14:29:55 EST
Did the installation program run in a graphical mode?
Comment 2 Justin Churchey 2003-01-14 15:15:59 EST
Yes, the only mode I've tried to install is Graphical.  I would try text mode,
but do not know what packages i would have to reinstall on 8.0 to restore my
previous X configuration if something should go wrong.  Because even after the
installation, X would not work.  I've checked the media and even ran anaconda on
another system (w/ different hardware of course).  I would run text install if I
knew X would work afterwards, but I doubt it would.
Comment 3 Jeremy Katz 2003-01-16 11:00:37 EST
If it also doesn't work post-install, then it's likely a more general XFree86
problem
Comment 4 Justin Churchey 2003-01-16 12:02:41 EST
I will try to perfrom a text-base installation when I get the chance to see if
that helps out.  It's odd that the XFree86 of this RH version does not work like
the older versions.  Any idea why?
Comment 5 Justin Churchey 2003-01-17 12:41:52 EST
Text-based installation completed.  Boots up in console by default (kind of 
unusual).  Something wrong w/ montior frequency I think, but not sure.  Check 
default frequencies for my montiror (compaq P50).
Comment 6 Mike A. Harris 2003-01-18 06:31:52 EST
Please run redhat-config-xfree86 by hand, and test the X server.  If
it still fails, please attach your X config file, log file to the bug
report using the link below, and mimetype text/plain
Comment 7 Justin Churchey 2003-01-19 14:59:32 EST
Ok, this installaton does not automatically boot me into console mode.  Is there
anyway I can force that on boot?
Comment 8 Mike A. Harris 2003-01-24 08:49:13 EST
Why is this reported against 8.0?  Should be reported against the beta.
Comment 9 Justin Churchey 2003-01-24 10:29:11 EST
Sorry about that, I could not find BETA on any version list.  So, I chose eight
and specified the Beta version in the Subject Line and report. If anything, I
thought it would be forwarded to the correct person.
Comment 10 Mike Chambers 2003-02-10 22:37:25 EST
If you want to do a text based install, at the boot prompt, type linux text or 
just text I believe to try installing in text mode.  If you get it to install, 
then try running redhat-config-xfree86 to see if you can configure your card.  
Also if it does not, post your config file and xfree log so it can be better 
troubleshooted, thanks.
Comment 11 Justin Churchey 2003-03-02 18:31:27 EST
Where is the XFree log and the config file locates so that I may post them?
Comment 12 Justin Churchey 2003-03-02 18:41:38 EST
After running redhat-config-xfree86, the screen flickers and the prompt returns
w/ illegible error messages.  Illegible because the screen contains horizontal
lines.  I also need to know a way to force the installation to boot into a
text-based login.  I have the system installed in text-mode, but it wants to
startx at bootup.  Is there anyway I can force a text login?
Comment 13 Mike Chambers 2003-03-02 20:53:24 EST
Config and log files are found in below paths..

/var/log/XFree86.0.log
/etc/X11/XF86Config

To have your system boot to a login prompt, edit /etc/inittab and look for the
below line..

id:5:initdefault:

change it to below (5 to a 3)..

id:3:initdefault:

Then reboot.

Note You need to log in before you can comment on or make changes to this bug.