Bug 818355 - Terminology Change: Contract Number -> Contract
Terminology Change: Contract Number -> Contract
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.9
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-05-02 16:30 EDT by Matt Reid
Modified: 2013-01-07 22:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:52:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
contract-number (150.54 KB, image/png)
2012-06-25 08:13 EDT, J.C. Molet
no flags Details
Contract Number -> Contract on GUI (103.75 KB, image/png)
2012-07-30 17:34 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Matt Reid 2012-05-02 16:30:19 EDT
Description of problem:
As part of our terminology alignment, Katello, RHSM Web and Subscription
Manager should all refer to "Contract Number" as just "Contract" in the future.
Comment 1 RHEL Product and Program Management 2012-05-03 11:17:34 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 J.C. Molet 2012-06-25 08:13:11 EDT
Created attachment 594170 [details]
contract-number

Testing with Versions:

python-rhsm-1.0.2-1.git.2.d5c3d05.el5
subscription-manager-1.0.4-1.git.20.0466bff.el5
subscription-manager-firstboot-1.0.4-1.git.20.0466bff.el5
subscription-manager-gui-1.0.4-1.git.20.0466bff.el5


There seems to have been no change here.  Attached screenshot shows instance of "Contract Number". Additionally, there are several mentions of this in all .po files:

❯ grep -r "Contract Number" . | grep -v \#
./pt_BR.po:msgid "Contract Number"
./pt.po:msgid "Contract Number"
./or.po:msgid "Contract Number"
./pa.po:msgid "Contract Number"
./de_DE.po:msgid "Contract Number"
./ml.po:msgid "Contract Number"
./bn.po:msgid "Contract Number"
./te.po:msgid "Contract Number"
./ta_IN.po:msgid "Contract Number"
./kn.po:msgid "Contract Number"
./ru.po:msgid "Contract Number"
./bn_IN.po:msgid "Contract Number"
./es.po:msgid "Contract Number"
./ja.po:msgid "Contract Number"
./ta.po:msgid "Contract Number"
./zh_CN.po:msgid "Contract Number"
./it.po:msgid "Contract Number"
./es_ES.po:msgid "Contract Number"
./de.po:msgid "Contract Number"
./mr.po:msgid "Contract Number"
./gu.po:msgid "Contract Number"
./fr.po:msgid "Contract Number"
./as.po:msgid "Contract Number"
./hi.po:msgid "Contract Number"
./keys.pot:msgid "Contract Number"
./ko.po:msgid "Contract Number"
./zh_TW.po:msgid "Contract Number"


Throwing back.
Comment 4 Bryan Kearney 2012-07-18 11:33:20 EDT
Available in 1.0.10 or later.
Comment 6 Sharath Dwaral 2012-07-30 17:34:58 EDT
Created attachment 601346 [details]
Contract Number -> Contract on GUI

The above screenshot shows the cange to Contract

Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.0.11-1.git.3.b3c4a8b.el5
subscription-manager-1.0.11-1.git.3.b3c4a8b.el5
subscription-manager-migration-data-1.11.2.2-1.git.2.c3c8e22.el5
python-rhsm-1.0.4-1.git.6.19a55da.el5
subscription-manager-firstboot-1.0.11-1.git.3.b3c4a8b.el5
subscription-manager-migration-1.0.11-1.git.3.b3c4a8b.el5

CLI verification:

# subscription-manager list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name:    	Shared File System
SKU:                  	sfs
Pool Id:              	8a90f82438b9a7380138b9a80bfb023b
Quantity:             	10
Service Level:        	Layered
Service Type:         	
Multi-Entitlement:    	No
Ends:                 	07/23/2013
Machine Type:         	physical

Subscription Name:    	Management Add-On
SKU:                  	management-100
Pool Id:              	8a90f82438b9a7380138b9a80ce4025b
Quantity:             	500
Service Level:        	
Service Type:         	
Multi-Entitlement:    	No
Ends:                 	07/23/2013
Machine Type:         	physical

# subscription-manager subscribe --pool 8a90f82438b9a7380138b9a80ce4025b
Successfully consumed a subscription for: Management Add-On
# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+

Subscription Name:    	Management Add-On
Provides:             	
SKU:                  	management-100
Contract:             	120
Account:              	12331131231
Serial Number:        	2477995900061500233
Active:               	True
Quantity Used:        	1
Service Level:        	None
Service Type:         	None
Starts:               	07/23/2012
Ends:                 	07/23/2013


It is verified at above mentioned instances but fail for one instance mentioned below.



# grep -r "Contract Number" /usr/share/rhsm/

./subscription_manager/gui/data/subdetails.glade:                                  <atkproperty name="AtkObject::accessible-name" translatable="yes">Contract Number</atkproperty>


Actual Result: 
Shown Above

Expected Result:
"Contract Number" should not appear in *.glade 

Moving bug back to NEW - FailedQA
Comment 7 William Poteat 2012-08-02 10:13:11 EDT
Commit e21d3c86a888e57dc1a0718a336f72835ee21b6d
Comment 8 Sharath Dwaral 2012-08-03 10:17:03 EDT
Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.12-1.git.6.1cb2247.el5
subscription-manager-1.0.12-1.git.6.1cb2247.el5
subscription-manager-firstboot-1.0.12-1.git.6.1cb2247.el5
python-rhsm-1.0.4-1.git.7.47e5112.el5
subscription-manager-migration-data-1.11.2.2-1.git.2.c3c8e22.el5
subscription-manager-gui-1.0.12-1.git.6.1cb2247.el5

Verification:

# grep -r "Contract Number" /usr/share/rhsm/

Moving Bug to VERIFIED
Comment 10 errata-xmlrpc 2013-01-07 22:52:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.