Bug 818363 - Bash Completion not working after update to f17 from f16
Summary: Bash Completion not working after update to f17 from f16
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: bash-completion
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-02 20:57 UTC by hannes
Modified: 2012-05-03 19:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-02 22:07:58 UTC
Type: Bug


Attachments (Terms of Use)

Description hannes 2012-05-02 20:57:38 UTC
Description of problem:
I don't have a proper bash-completion for many programs.
For example I could not use bash-completion with any systemctl commands.
systemct would be expanded to systemctl but any further command like restart etc. and the name of the service is not expanded.


Version-Release number of selected component (if applicable):
bash-completion-1.99-1.fc17.noarch


How reproducible:
Always


Actual results:
No completion at all.

Expected results:
Completion and presentation of possible commands.


Additional info:
I used to have the entry 'source /etc/bash_completion' in my .bashrc but since all is moved to /etc/bash_completion.d/ I tried to use something like 'source /etc/bash_completion.d/*' and various variants but it didn't work.

Comment 1 hannes 2012-05-02 22:07:58 UTC
Changing source /etc/bash_completion to source /etc/profile.d/bash_completion.sh solves this.
Sorry for the noise.

Comment 2 Ville Skyttä 2012-05-02 22:20:02 UTC
You shouldn't need to source anything yourself "manually" in ~/.bashrc or friends, /etc/profile.d/bash_completion.sh should be automatically loaded by bash.

Comment 3 hannes 2012-05-02 22:24:23 UTC
Well that's not happening apparently. How is it started?

Comment 4 Ville Skyttä 2012-05-03 07:38:03 UTC
/etc/profile and /etc/bashrc (sourced by the default ~/.bashrc) source everything in /etc/profile.d.

Comment 5 hannes 2012-05-03 19:11:54 UTC
Hmm, that's my .bashrc:
PS1='\u@\h:\[\033[01;34m\][\W]\$ \[\033[00m\]'
alias ll='ls -la'
gh(){ grep "$*" "$HISTFILE"; };
#source /etc/profile.d/bash_completion.sh
#export GTK2_RC_FILES=/home/johannes/.gtkrc-2.0
alias lwh="ls -alt | head -20"
#alias rm="rm -i

Is there a way to find a complete clean .bashrc or the default one for fedora?

Comment 6 hannes 2012-05-03 19:51:11 UTC
Ok, nevermind, fixed it now by copying over some lines from the bashrc of a newly created user.


Note You need to log in before you can comment on or make changes to this bug.