This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 818363 - Bash Completion not working after update to f17 from f16
Bash Completion not working after update to f17 from f16
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bash-completion (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 16:57 EDT by hannes
Modified: 2012-05-03 15:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 18:07:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hannes 2012-05-02 16:57:38 EDT
Description of problem:
I don't have a proper bash-completion for many programs.
For example I could not use bash-completion with any systemctl commands.
systemct would be expanded to systemctl but any further command like restart etc. and the name of the service is not expanded.


Version-Release number of selected component (if applicable):
bash-completion-1.99-1.fc17.noarch


How reproducible:
Always


Actual results:
No completion at all.

Expected results:
Completion and presentation of possible commands.


Additional info:
I used to have the entry 'source /etc/bash_completion' in my .bashrc but since all is moved to /etc/bash_completion.d/ I tried to use something like 'source /etc/bash_completion.d/*' and various variants but it didn't work.
Comment 1 hannes 2012-05-02 18:07:58 EDT
Changing source /etc/bash_completion to source /etc/profile.d/bash_completion.sh solves this.
Sorry for the noise.
Comment 2 Ville Skyttä 2012-05-02 18:20:02 EDT
You shouldn't need to source anything yourself "manually" in ~/.bashrc or friends, /etc/profile.d/bash_completion.sh should be automatically loaded by bash.
Comment 3 hannes 2012-05-02 18:24:23 EDT
Well that's not happening apparently. How is it started?
Comment 4 Ville Skyttä 2012-05-03 03:38:03 EDT
/etc/profile and /etc/bashrc (sourced by the default ~/.bashrc) source everything in /etc/profile.d.
Comment 5 hannes 2012-05-03 15:11:54 EDT
Hmm, that's my .bashrc:
PS1='\u@\h:\[\033[01;34m\][\W]\$ \[\033[00m\]'
alias ll='ls -la'
gh(){ grep "$*" "$HISTFILE"; };
#source /etc/profile.d/bash_completion.sh
#export GTK2_RC_FILES=/home/johannes/.gtkrc-2.0
alias lwh="ls -alt | head -20"
#alias rm="rm -i

Is there a way to find a complete clean .bashrc or the default one for fedora?
Comment 6 hannes 2012-05-03 15:51:11 EDT
Ok, nevermind, fixed it now by copying over some lines from the bashrc of a newly created user.

Note You need to log in before you can comment on or make changes to this bug.