Bug 818376 - X freezes when scrolling on Firefox
X freezes when scrolling on Firefox
Status: CLOSED DUPLICATE of bug 839400
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 18:04 EDT by Sergio Durigan Junior
Modified: 2012-07-27 16:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-27 16:02:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of X when it freezes (5.14 KB, text/plain)
2012-05-04 21:32 EDT, Sergio Durigan Junior
no flags Details

  None (edit)
Description Sergio Durigan Junior 2012-05-02 18:04:47 EDT
Description of problem:


X server is freezing when I use scroll on Firefox.  Only connecting via SSH using another machine and issuing a `kill -9' on the X server "solves" the problem.

This problem happens randomly, sometimes I use Firefox for 2 weeks without problems, sometimes it freezes in less than 24 hours.

Version-Release number of selected component (if applicable):

xorg-x11-drv-intel-2.17.0-8.fc16.x86_64
firefox-12.0-1.fc16.x86_64

How reproducible:

As I said above, this problem happens randomly.  Nothing strange appears on /var/log/messages.

Steps to Reproduce:
1. Open Firefox
2. Use scroll until X freezes
3.
  
Actual results:

X freezes.

Expected results:

X should not freeze.

Additional info:

I can provide additional info if needed.
Comment 1 Adam Jackson 2012-05-03 16:48:15 EDT
When this happens, can you ssh into the machine and attach gdb to the X server?  If so, where does the backtrace show you stuck?

Also, is there anything in /sys/kernel/debug/dri/0/i915_error_state when this happens?
Comment 2 Adam Jackson 2012-05-03 16:48:44 EDT
Also, which gpu is this with?  The output from 'lspci -n -s 0:2' is sufficient.
Comment 3 Sergio Durigan Junior 2012-05-04 16:41:15 EDT
(In reply to comment #2)
> Also, which gpu is this with?  The output from 'lspci -n -s 0:2' is sufficient.

Hi Adam,

Thanks for the reply.  This is the requested output:

00:02.0 0300: 8086:2a42 (rev 07)
00:02.1 0380: 8086:2a43 (rev 07)

In a moment I will try to cause X to freeze, ssh into the machine and run GDB as requested.
Comment 4 Sergio Durigan Junior 2012-05-04 21:31:07 EDT
Here is the full backtrace of X when it freezes.  Also, /sys/kernel/debug/dri/0/i915_error_state doesn't show any errors.
Comment 5 Sergio Durigan Junior 2012-05-04 21:32:27 EDT
Created attachment 582241 [details]
backtrace of X when it freezes

This is the X backtrace when it freezes.
Comment 6 Sergio Durigan Junior 2012-05-16 23:48:44 EDT
Ping.

This issue has just happened to me.  Is there any other information you need for this?

Thank you.
Comment 7 Miroslav Mamrak 2012-07-27 16:02:50 EDT
There is a newer report with the same bug, with more useful informations. Also that report is for Fedora 17.

https://bugzilla.redhat.com/show_bug.cgi?id=839400




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 839400 ***

Note You need to log in before you can comment on or make changes to this bug.