Bug 818419 - missing header eimd5.h
missing header eimd5.h
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: erlang (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-02 23:45 EDT by xaoc
Modified: 2012-09-07 07:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-05 19:38:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xaoc 2012-05-02 23:45:31 EDT
Somehow file eimd5.h is missing.
Expected to be found in:
/usr/lib64/erlang/lib/erl_interface-3.7.5/src/misc/eimd5.h
as part of erlang-erl_interface-R14B-04.1.fc16.x86_64 package.
Comment 1 Hans Ulrich Niedermann 2012-05-20 09:43:21 EDT
Is src/misc/eimd5.h really part of the EI API?

The location of eimd5.h suggests that it is not, and thus is rightly not shipped.
Comment 2 xaoc 2012-05-20 12:11:39 EDT
Looks like this could be workarounded by using openssl/md5.h in user's code. Still I think it would be good to include Erlang's src/misc/eimd5.h in the distribution, as is done in Erlang Solution's rpms. Just for consistency.
Comment 3 Serge 2012-05-20 12:39:24 EDT
Unfortunately the Erlang distribution didn't do a complete job at properly exporting all functions needed to connect to an Erlang node in non-blocking manner.  Hence some low-level function calls are needed from erl_interface-3.7.5/src/*/*.h headers which are actually included in ei.a.

See for example eixx project using ei (https://github.com/saleyn/eixx)

As a result this request definitely has a merit!
Comment 4 xaoc 2012-05-20 13:35:06 EDT
Since Erlang distribution is already divided into enormously big amount of small packages, I think it would be easy to add one more - erlang-erl_interface-dev or erlang-erl_interface-src package including the whole /usr/lib/erlang/lib/erl_interface-$vsn/src to cover this need.
Comment 5 Fedora Update System 2012-06-26 08:55:39 EDT
erlang-R15B-01.4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/erlang-R15B-01.4.fc16
Comment 6 Fedora Update System 2012-06-26 08:55:49 EDT
erlang-R15B-01.4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/erlang-R15B-01.4.fc17
Comment 7 Peter Lemenkov 2012-06-26 08:59:41 EDT
Folks. sorry for the delay. Please try these packages.

Beware - these ones are with R15B and here is a list of added/removed functions between R14 and R15:

* http://peter.fedorapeople.org/R14-R15.diff.log
Comment 8 Fedora Update System 2012-06-26 17:25:23 EDT
Package erlang-R15B-01.4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing erlang-R15B-01.4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9926/erlang-R15B-01.4.fc16
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-07-05 19:38:00 EDT
erlang-R15B-01.4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-09-07 07:25:46 EDT
erlang-R15B-01.4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.